Faulty Pi Zero?


#1

Hello There!

I’m trying to set up a Retopie image on my Pi zero (v1.3 without WiFi or BT) and I’m facing a lot of problems, it cost a lot to make it boot, I have to reset the board by switching off power supply until it finally boots (Maybe 3 or 4 times) After that the Retropie systems is freezing within 3 o 4 minutes or even not reaching the fronted (it blocks during boot up procedure).
I’m using retopie 4.1 and I’m wondering whether mi pi is faulty or something, I’ve tried with 3 different SD cards, several PSU, analog or HDMI video output but the result is the same.
I’ve read something related with a bad revision code programmed in a post of raspberrypi forum facing a very similar problem…I’m block here I don’t know how to solve this problem. Any ideas?
Thanks


#2

the obvious suggestion would be to try Raspbian first. If it boots then you’ll know it it something to do with RetroPie, rather than the hardware.

if it boots in Raspbian - I advise trying Jessie Lite for the fastest way to cli - and you can run the following, please post the output here:

curl https://get.pimoroni.com/diagnostic | bash

and, if possible:

dmesg > dmesgoutput.txt

… the later should output the boot up messages to a file that you should be able to move to your /boot partition and post here using a different computer. It may contain some clue about what is going on.


#3

Hello again an thanks for your fast reply.

I did two more test, the first one was to boot with my SD and gamepad in other Pi Zero and it works fine no freezing. After that I went to Raspiban as you suggested, it takes a lot of to get it boot, fixed light or even no light but at the end it boots, also getting some random freezing buy I observed something weird, when I touch the USB wire the screen goes green and the Pi get blocked, even with a minor touch one of this times a message came up, I took a picture in case it helps.


#4

what is plugged in the USB port, and how? is it an adapter provided along the purchase? how long have you had the Pi - did it work properly at first?


#5

A micro USB to USB adapter is plugged to Pi, I’ve test this adapter in other Pi to discard a failing adapter, this adapter came with a Tablet I think. I’ve tried using a wired gamepad and also a wireless keyboard with the same result.I had the Pi for 3 weeks and this is my first try then I could say that it never works properly, but anyway I did some soldering over TV out, not my first time I have some expertise on soldering, I’m just saying that I have physically modified the board then I could be the failing source.Anyway I would like to know whether is possible to save it, maybe directly soldering the USB gamepad and supply to the pads located under the USB connectors…
Thanks again.