Raspberry Pi Zero W not booting


#1

Hi guys,

Just recieved a brand new Rpi Zero W. I have used these before with much success. But this one is giving me a big headache.

This particular Rpi is not booting up properly. I have tried different sd cards, different psu`s and different cables. As well as different images and processes for writing the image to the card.

The installation process always results in a black screen, and everything halts to a complete stop.

I also have an Rpi 3b+ and have tried to exchange sd cards and the Rpi 3b+ works with the card I had in the Zero.

Any ideas?

Thanks


#2

As far as I know Raspbian is backward compatible with all versions of Pi. It that card boots in a 3B+ no problem, its not an SD card issue. Do you ever see anything on screen? Sounds like a dud Pi, rare but it does happen.


#3

Yes, the results is different, from card to card. Sometimes it goes through a small checklist before ending up in a non responsive desktop, without the shortcuts. Sometimes I only see one Raspberry.


#4

Using the same power supply as in your Pi 3B+? It does, indeed, sound like a dud Pi Zero. If you haven’t swapped out the power supply or tested it with something else, though, that may be worth a try.


#5

I have also tried different psu’s. The one I am currently using is a 10Ah one. Should be enough😊


#6

10A seems like a lofty claim for a microUSB power supply (makes me wonder if it’s just cheap garbage with a sticker full of dubious claims), you couldn’t pull 10A through a microUSB port, or the cable itself!

I suspect you know what you’re doing and have been thorough though! :D If you bought the Zero W from us, you should drop us a line at support@pimoroni.com


#7

I have a 5V 10 A switching power supply I use on my bread board rig. It uses a barrel connector though. ;) Looks like a laptop power pack. Nice beefy cable too. I just made up my own custom power feeds to what it drives. Pi, touch screen audio amp etc. Maybe he did something similar?


#8

Yeah I know. It is a China psu, with a sticker on it. I have sent a email to support, and it is already resolved. Thank you guys!