PiZero won't boot


#1

I have bought 2 Pizeros over that last couple of months and the first one just stopped working for some reason, so I bought another one.
I tried the same micro sdcard in the new PiZero, but it would not boot up, and neither was the card recognised in windows and ubuntu. I bought a new sdcard , then put the raspian latest image on that said card and tried that. Same thing as before , the PiZero wouldn’t boot up.

I used etcher in Ubuntu to burn the image and after it was done, the card was recognised in both ubuntu and windows. I then put the new card into the new PiZero and powered it, but still no bootup, even after leaving it for a few minutes.
I took out the card only to find that again it was not recognised in both the said systems.
Anyon any ideas as to what is or was wrong.


#2

Try a different SD card. Its what I would do.
Windows will see part of the card, the Fat32 Boot partition. It won’t see the other partition though and will prompt you to format it. Close that prompt with the X and no harm done. Do one of the other options and it may overight your card. Just FYI in case you don’t already know.
If the new cards works in the second Zero, try it in the first Zero. It may have been an issue with that SD card al along.


#3

I have tried in this order:
Initial 16Gb Sandisk card: Failed to boot
New 16Gb Sandisk card: Failed to boot
New 8Gb sandisk card: Failed to boot.

I have given 2 of the sdcards to a freind to check them for me, and he’ll let me know by Monday

Thanks


#4

Ok, thanks for the extra info. Does the status LED light up?
Have you tried a different power supply?
Or tried that power supply on a known good working Pi?
What’s connected to the Pi? I would go with just what’s needed, keyboard mouse and monitor.


#5

No LED does not light up, which I was waiting for.
Yes tried 2 different power supplies 5v 2A
Yes I tried the Power Supply in a working PiZero, and it was ok.
The connections to the PiZero are: Power Supply, Keyboard, Mouse and Monitor.

I have burnt the same raspian image to a 16Gb SD card, not microsd, and tried it in a windows machine, and it was part as you say. No, windows did not see or recognise any of the card, and wanted to format it.
I put that card back into Linux and it was immediatly recognised. Trouble is now, it won’t fit into the PiZero card slot, lol


#6

Windows should see the FAT formatted Boot partition. It will show up in File explorer and disk management.
It sounds like you have two dead Pi Zero’s? You may be able to return and or get a refund for the second one, how long have you had it?


#7

The first Pizero was bought on or about 11/04/2018
The 2nd one was bought on or about 11/09/2018


#8

I think its 30 days for refund, if you bought the second one from Pimoroni go the Shop page and there should be a contact us link at the bottom. Also put a link in there to this thread. Then see what they say.

If you take a working SD card from another Pi, that has the latest Raspbian on it, and it doesn’t work in that Pi Zero, its a hardware issue. Pi or Power supply usually. Unless the keyboard or mouse is shorting out the USB +5V or something?


#9

I would rather not take out a sdcard from a working Pi as I do not want to risk it like the other 2 cards I used. Something seems to be screwing up the files on the card after it was inserted into the PiZero.

Anyways, I have submitted a request for refund or replacement, so we’ll see what happens next week.


#10

Totally agree, if something is damaging the SD card I wouldn’t want to do it either. The win32diskimager will make an image from a card. https://sourceforge.net/projects/win32diskimager/
I don’t know if there is a Linux Version though. Then if the card gets corrupted you could reimage it back without starting from scratch. Assuming no physical damage is being done to the card.


#11

In Linux there is a program called etcher, which does more or less that same as win32 diskimager, and I have used it to burn an image onto about 3 other cards for Pi’s, and had no problems until now.

When the card was removed from the PiZero, it was not recognized by any OS at all.So I could not re image it as I though I could do. So upto press I have 3 cards that are up the creek and will see what my friend says on Monday about them.


#12

I use Etcher to image my cards. It can’t make a backup “image of the card” though. Win32 can do that. I have a couple setups with lots of stuff installed etc that I don’t want to have to redo from scratch so when its all setup and working I make an image of the card and save it for latter on if needed.
You may be able to recover the card from diskpart in Windows. Open an admin command prompt and type diskpart. Then do a list disk. If the SD card shoes up in the list do a select disk #. # being the disk number of the SD card. Then try a cleanall. Then “create partition primary” > “format fs=fat32”. You might get lucky and get the card back to usable again.


#13

Strange you mention diskpart, as I used it earlier to clean a spare hard drive. Thanks for the info about cleaning the sdcard, I never thought to do that.


#14

My friend gave me the 2 cards back earlier and said neither could be recovered, so I used diskpart to have a look at them. The 16Gb card is not recognised by diskpart or any other program including the HP format tool. The 8Gb card was recognised but only the first 121mb, and nothing else, in both diskpart and HP USB format tool.


#15

I’ve had one card fail on me that showed up as 30 kilobytes or something. I tried a few things but in the end I binned it and replaced it with a new one.
And I had another card just kind of disappeared, Etched didn’t see it, and Windows file explorer didn’t see it. Not even a prompt to format it. Once I did a “clean all” in diskpart it was fine again. Corrupted file system or something?


#16

Bit of a leftfield solution, but I have found that seemingly corrupt cards can sometimes be recovered by formatting them in a digital camera.

Use the camera’s format function.

Dunno why it works but it usually does.


#17

What power supply were you using? Is there anything particular about your setup?

It’s pretty curious a second Pi Zero wouldn’t work, and also a second SD card, but based on the order of events it’s possible that the first Pi fried the card and the fried card then fried the second Pi which fried the second card. This is a complete and total unsubstantiated reach, though.

There must be some common thread to your setup that can explain multiple card/Pi failures since it’s rare enough to even have a single Pi Zero fail like this.


#18

Power supply is / was a 5v 2.5amp job, although not specifically for any pi

Like I said before, all I had connected to the Pi Zero was monitor, keyboard and mouse. There was nothing else attached nor anything on the pins.

The only thing I would suspect is the actual image file, but if so why would the sdcard still show in Nautilus on Ubuntu.

And as you say it must be a common thread to do what happened. Maybe the sdcard I used, both being Sandisk, but could be fakes. The 8Gb one I bought the other day was from a local shop and in a what looked like genuine sandisk packaging. I have ordered 2 more micro sdcards from what I would term as a reputable dealer, and waiting for them to arrive. I’ll test them first to be sure


#19

Image your cards, and then boot them up first time in a working Pi that you trust. Sandisk is my personal preference. My Sandisk cards have been pretty well rock solid. My Lexar cards not so much. I haven’t had an Lexar cards fail, but other weird things have happened that are making me want to avoid using them in a Pi.

If your Power Supply is or was a “Phone Charger”, you might want to get an official Pi Power supply.


#20

No, I wouldn’t say it was a phone charger, and I only use usb leads for that. Yes Sandisk are usually my first choice, but the trouble is that there are so many fakes now.
Last year I bought a USB stick from an ebay seller. When I got I tested it, and it was fake.
I have a Pi Zero which is not running at the moment, so I’ll use that for a test, and hope it doesn’t screw up on me.