Pi zero not booting


#1

Hi,

Got a raspberry pi zero a few days ago but have had no luck booting any current Raspian lite/full//noobs, Retropi or Recalbox os onto the device. The only Raspian img that booted was from 21/11/2015.

Iv’e tried 6 sd cards, 4 keyboards, 3 plugs/wires but still seem to get a selection of errors on first boot

Any help would be appreciated.

Thanks

Various errors encountered:

unhandled fault: alignment exception
internal error: : [#1] ARM

unable to handle kernal paging request at virtual address fffffffe

kernal panic not syncing attempting to kill init!

unable to handle kernal NULL pointer at dereference at virtual address

NOOBS ERROR


#2

more recent images uses a different type of compression, which I guess your imager on Windows is struggling with. Try etcher, it’s the NKOTB everybody is raving about these days!


#3

Hi, thanks for the reply.

Unfortunately I’ve already tried that.

I’ve used

windows: formatter, win32imager
mac: formatter, etcher and applepi baker
linux: dd

All seem to have the same result.


#4

hum, if your Pi boots from a 1-year old image I don’t think it would be a hardware fault… not likely at least.

do you have any other Pi to test one of these imaged SD to see if you get similar results?


#5

Unfortunately i don’t.


#6

I’m sure if you shoot support an email, they’ll be happy to pop a NOOBS card in the post for you… personally I don’t think there is anything wrong with the zero or it wouldn’t boot at all from any image (particularly a fairly old one).

… of course, that won’t solve your issue burning images as you see fit but at least that will entirely rule out it’s (somehow) an issue with the Pi itself.


#7

Will do, thanks for the advice.


#8

one thing you can try though, since you have access to a Mac, is uncompress the image with The Unarchiver followed by flashing the resulting .img with dd Utility.

… that is a combo I use daily and can vouch that you should get usable flashed images out of Raspbian and Retropie (and many others).


#9

Thanks,

I’ll give it a shot.