Pi Zero w CRASH CRASH CRASH..... crash

Hi there…
I have been going round in circles on this for months (spend an hour or two crash crash crash, then come back to it weeks later), and can only assume hardware error by this time, having tried several sd cards, multiple light installs and most recently a high end data profiled card.
The zero fails every time on apt upgrade or any other even slightly ‘weighty’ install and even a gentle minor update from a fresh light install.
I am always running this headless with the latest light version.
I have tried several power supplies and using various iterations of usb and soldered direct power connectors, including the smoothest of 5v via more than one ATX power supplies.

I bought this zero sometime ago from pimoroni and have had this issue from the start, yet with always so much else on I have taken a stop start approach.
So any trouble shooting tips and or suggestions very very very welcome.

thanks in advance

just tried installing PiHole a few times using each available method… it gets to stage one… [i] Update local cache of available packages… then freeze dead

I have the same issue with one of my Pi A+'s. Flash the SD card with a new image, put it in, and it boots up just fine. Even gets though the setup wizard part way. Then locks up when doing update / upgrade.
I started over exited the wizard and did things manually, same deal, froze during update / upgrade. I’ve had this A+ for many years and this is the first issue I’ve ever had with it.
IMHO It’s got to be a hardware issue on the Pi. I tried a couple of different SD cards and a second Pi A+ was fine when booted with the same version of PiOS. I even went back to an older version of Raspbian, one I knew I had previously run on that Pi, still locked up.
I think you will find that even if you don’t do an apt update and upgrade, it will still lockup as you install other software or leave it running some code.

1 Like

Yes, this sounds most familiar and I would also expect it to lockup sooner than later regardless.
It’s good to know (apart from the grief you are having) that I’m not alone in this and wonder if Pimoroni or anyone on the forums have any ideas on a way to check the hardware or logs to troubleshoot this.

I have cleaned the zero using IPA just in case there were any dust related shorts yet nothing seems to help so far.

This is the first time I have seen this failure mode. For me, hardware wise, its been a pretty cut and dried my fault issue. I let the magic blue smoke out, end of story. Pi wise anyway.
All my software issues have been with addons, breakout boards, Hats, pHats etc. I have had hardware issues with those, but unplug them and the Pi works OK.

same here, I have also blown a couple in the past yet these (I have two like this) have worked, then sat in a box and now don’t work…

I’m trying to find some kind of diagnostics I can run through… anyone?

My A+ was in use for a long time, many years chugging away with a sense hat on it. I don’t think it sat on the shelf for very long before I tried to repurpose it. I still have it kicking around here somewhere. It has to go to the enviro depot and i haven’t bothered.
You could try posting on the Raspberry Pi Forum, asking what to try / check? If anybody would know I would think it would be somebody over there.
I’m a retired electronic technician but my Linux skills are basic as far as troubleshooting a Pi goes.