Raspberry Pi Zero W fails to boot/update/install : kernel panic - Raspbian


#1

Hi,

I run into troubles with a Pi Zero W and Latest Raspbian.
Please note that I’m pretty experienced with the PIs: I Use them since the first version, got several Pi Zero and another Pi Zero W from another retailer (this last one runs fine).

This seems to be an issue with the specific Pi Zero W I just got from Pimoroni:
I use the latest Raspbian Image.
When booting, or apt-get upgrade, or some apt-get install, I get kernel panics and Oops.
(The other Pi Zero W I got runs fine for all this)

This looks like a SD problem, so here is what I tried :

  • Use other SD cards
    I tried with more thant 5 sd cards (class 10, compatible, new ones as well as sd cards that works on other PIs)
    Same errors each time. So far, I never get the Pi to apt-get update without crashing.
    Tested on too many sd cards and sd cards knows to work on other Zero W, so the issue if definitely not the sd card.

  • Make sure the power supply is solid.
    I used a 2 Amp power supply, a short usb cable. I tried with wlan deactivated. No change.
    No doubt about the power supply.

  • install and run rpi-update
    I could install rpi-update and run it.
    Rebooted, then same thing, apt-get upgrade or dist-upgrade crashes.

I spent several hours burning sd cards and trying all I thought of.
Wifi only, ethernet adapter only, ethernet over usb only: no change at all, always the crashes.

So it looks like this Raspberry or at least its card reader is defective.
Is there anything else to try ?


#2

it looks like bad data transfer from/to the SD. I think your tests would rule out a faulty SD, so it must be the connector on the Pi itself… does it look misaligned or a bit too loose for comfort?

either way, shoot an email to support@pimoroni.com and they’ll help you with this matter.


#3

Thanks,

I emailed.
The SD connector looks fine, well aligned and not too loose.


#4

Hi,

Guess you’re pretty busy, no answer from the support yet.


#5

Aye. I’ve poked the support staff for you, though.


#6

Great, got answer from support, and I will send the unit back for further investigation too.

Thanks to you all!


#7

I’ve got exactly the same problem and tried to contact Pimoroni twice without response yet. Who can help me waking up the support staff? ;-)

edit: I also tried with several (new and old) SD cards, all of them run flawlessly in a Pi 2 (using the same power supply). This is what I get on every boot:
https://s24.postimg.org/ru1qt9qit/pi-crash.jpg


#8

Hi, you should have received a reply today- we don’t respond to support tickets over the weekend and I have a suspicion Matt was ill on Friday but I’m not certain (I’ve been spreading the plague around to everyone lately with the most heinous cough.)

Your testing sounds pretty thorough, but please humour Matt’s sanity checks and let us know. We’ve got your back!


#9

Okay thanks, got a response!