Problem with Pi Zero W and wireless/bluetooth


#1

HI all,

I have a problem with a new (1.3) Pi Zero W recognizing wifi or bluetooth.

I have tried with a (slightly, 11/16) older Raspbian version and a fresh Raspbian install today.

It boots up fine but neither bluetooth or wifi are detectable.

Weirdly my other Pi Zero W has working wifi and bluetooth with the same SD. (Why dont i just use this? I soldered the header on upside down :/).

I am using the power supply from pimoroni.

I ve had a look online and can’t see a glaringly obvious solution; the plus side is I have learnt how to overwrite and install a fresh Raspbian image to SD.

I wondered if anyone else had the same problem; any advice gratefully received. Thanks!


#2

This question is answered in the banner topic :D Look up, there, the big blue rectangle, with the “Zero W OS Compatibility” bit :P

You can also find it here: Pi Zero W: READ THIS FIRST!

But, yes, of course the Pi Zero W wont work reliably with an OS that was released before it was :D Support for the Zero W Bluetooth/WiFi was only added into Raspbian subsequent to its release.

I suspect you might be able to get an older OS version up and running by running sudo apt-get update and sudo apt-get upgrade but… well without WiFi that may be tricky (if you don’t have a USB ethernet adapter to hand).

Why the older version? Limited internet?


#3

Hi

No, I tried with the current version and it didn’t work so I tried with an older version which had worked on my other zero.

Both versions work on my older model zero.

Thanks


#4

Oooh, damn me for a horribly cynical lack of reading comprehension. I blame a lack of sleep :D Sorry!

If the same SD card isn’t resulting working WiFi in one of those Pi Zero Ws, then chances are there’s something wrong with it.

Have you run any debugging steps to see if the WiFi is detected, or if there are any errors?

I’ll fire up a Pi Zero and see if I can roll out some commands you can run to see what’s up!

Try:

dmesg | grep Bluetooth
dmesg | grep 80211
sudo lsmod

And see what you get out of it on your possibly-faulty-Pi-Zero-W


#5

Hi Phil

No problem :), appreciate the response.
I have run the … Hardware detector and it is being recognized as a zero 1.3; some people reported a false model detection with a zero being recognized as a pi 3.

I haven’t run any debugging

Cheers for help , Tom


#6

What ‘hardware detector’ are you referring to? What does the following yield for you:

curl https://get.pimoroni.com/diagnostic | bash

#7

Hi,

That command yields a lot of zeros.

I think I might reorder and try with another pi.

Thanks for your help, Tom


#8

doh, if you don’t have a network/wifi then that command will fail - my bad!

still you could run the following, just to be sure what hardware the system think it’s running on:
grep Revision /proc/cpuinfo

incidentally note that there is no Revision 1.3 of the Zero W, the current version is tagged as 1.1… it is both unimportant and important in that maybe you purchased / were sent the wrong hardware? you should be able to confirm that by checking the silk screen on the back of the Pi.


#9

see this pic for expected description:


#10

AHA!
I think you have solved it.
I ve been sent a Zero Pi 1.3 when i ordered a Zero Pi W :)


#11

Zoiks! I’ll get a replacement out in the post to you ASAP.


#12

Oh ok, brilliant

Thanks for the help :)

Tom


#13

I’ve bought 2 rpi zero w from you one as a replacement for the first just to see if it was just me being useless. It’s not. Got both booted up. Got both connected over virtual ethernet no wifi. Zero say no wifi at all. I’ve read that the device tree isn’t getting loaded properly on some badly set up boards.
I’ve tried to force the board revision. New old foods/ jessie lite. Tried everything. But nothing. No wifi.
Any chance of an exchange? I sort of need them.


#14

Sure- drop me a PM with your order number and I’ll look into it!


#15

Stupid question. How do I PM you on here?


#16

New zero pi w received with thanks and working fine 👍🤗🎊🎉


#17

Hi Phil.

It was 2 of these invoice numbers

redacted

Hope that helps.

Nick


#18

Yup, that should do!


#19

@NickRamsay sorry, just to check I’m on the right page here; are you failing to get WiFi working on two separate Pi Zero Ws, r did it work on the replacement but not the original?


#20

Hi Phil. It’s not working on either. I bought one extra as a replacement for the first.
No wifi on either.