Fried my RPi Zero 2 W with a pHAT stack?

Hi Pimoroni community:

I was lucky enough to grab a RPi Zero 2 W recently, and wanted among other things to work with some sensors - first attempt described here was a weight scale. I haven’t soldered anything since forever, so I got what seemed like a no-solder solution to my immediate needs while I practiced soldering on blanks. My parts list:

So the “wiring diagram” such as it is, consists of

  • RPI02W on the pHAT Stack
  • Qwiic pHAT on the pHAT Stack
  • Load cell wired to the NAU7802 which is Qwiic connected to the Qwiic pHAT

I’d successfully set up the pi (used the official RPi imager on Windows to burn latest OS to the microSD, a SanDisk 32GB), and had no trouble with the initial boot nor subsequently doing updates and installing some software that I expected to use. I successfully shutdown and powered back up several times. The green LED on the pi behaved as expected, lighting up and flashing when it was supposed to.

Whenever I handle any of the PCBs I wear a properly grounded wrist strap and only touch edges. I work on a silicone mat. With power off, I put the Zero2W (remember no header if that matters) and the Qwiic card (it has a female header) on the pHAT Stack. When I switched on power, the Zero2W green LED did not light up. I will note that the LED on the NAU7802 did light up, indicating it was getting its 3.3V power through the pins as expected; i.e., my power supply (official Raspberry Pi version by the way) did not die, and at least the 3.3V pins on the pHAT Stack are properly connected.

I read that at least for this particular Pi, one cause of an absent green LED is a bad SD card. Again, wrist strapped, powered down whenever I touched anything, I reseated the SD card. No. I re-imaged that SD card. No. I imaged another SD card, nope. No boot activity at all, no sign of life for the Pi.

All I can think is that I somehow fried the Pi. I was quite careful to try to avoid that. I never introduced external power to the system - power supply to the Pi was it - so nothing over 5V was ever present. I don’t see how I could have gotten even 5V where 3.3V were expected, or how I could have shorted anything.

I guess my questions are:

  • did I do anything obviously (obvious to you, not to me) wrong that could have fried my pi?
  • is it possible the pHAT Stack is defective and somehow fried my pi?
  • is there any way the Qwiic pHAT could be defective in a way that would fry the pi (I can’t imagine it)
  • how long will it be before I can get another RPi02W? I was feeling pretty lucky to have scored one.

I should maybe mention that I’m a retired theoretical physicist, thus the attempt to first do this project avoiding the soldering iron and even breadboards and jumper wires.

Thanks in advance for any advice, gentle scolding, or suggestions of what I might do to check the unlikely scenario that the board is not dead.


The Pi Zero needs a header on it for one thing. Just resting it on top of the male header on the pHat Stack isn’t going to work. Plus how did you orientate it on the phat Stack?

I had it in the bottom position as shown in the Getting Started article Getting Started with pHAT Stack

But I did have it in my head that I could use this board without having to solder on a header. There aren’t any traces on the surface of the pHAT Stack, so I still don’t see how I could have shorted anything.

I’m not sure it does me any good to solder the header on now, as it does appear dead. I of course tried booting it unconnected from the pHAT Stack board, and still no boot, no green LED.

From that guide: “One neat way to use pHAT Stack that we like is to solder a female header to the underside of a Pi Zero W and then mount it…” - so to be fair I should have been aware that soldering the header was still required.

And I presume the reason that it “isn’t going to work” is that you’re not guaranteed good contact with the pins to the holes/header footprint. But again, I’m not seeing where my Pi-killing mistake was.

Just realised your using a stock picture of the pHat stack,my post was useless! ;)

Yeah, it isn’t going to make good contact, not reliable enough for i2c to work correctly.
If you have a voltmeter handy carefully measure the 3.3V pin on the GPIO header. Best guess is the 3.3v pin got shorted to ground, or to the 5V pin. Either scenario will blow the 3.3V regulator on the Pi.
Did any of the pins on the pHat Stack male header gent bent?

I’ll have my multimeter back in hand next week (loaner that didn’t come back), but for now I subbed in an old 3B and used the gpio cable that came with the pHAT Stack to connect (hey, I didn’t have to solder anything!). I’ve at least verified that I can detect the scale device on i2c, so I’m back in business for working on this. I’ll update here with confirmation one way or the other on shorted pins on the Z2W. Thanks again.

If you use a female right angle header you can plug a Pi Zero vertically into the ribbon cable header. Saves space and all the ports are easy to access.
There is a pHat Stack in there under all the other bits.

Nice, and great idea! I’m on the alert lists for all the vendors for when they come back in stock, hopefully I’ll be able to grab another soon. And I’m practicing the soldering for when that day comes.

That pHat Stack also has a custom mode at the other end. It’s been cut back and has a 90 female on the end that i can plug into my Pi 400’s GPIO. Just have to remember to remove the Pi Zero first.