Getting to grips with the hardware


#1

Hi,

Whilst I’m comfortable with the unix/linux side of things and dont see a problem picking up python (eventually) I do need to get to grips with is the hardware side.

I’m quite new to the maker side of things and was hoping to start a little “project” of my own to get the kids involved in computers. My son has an old radio controlled car that had a bit of an accident and is begging to be used again.

My thoughts were to use a Pi Zero, WIFI adaptor (or the Pi Zero W!), some sort of motor/servo control, camera, range sensor and power it off a number of batteries (not entirely sure of the voltage requirements). For control I expect to be able to use a web front end of some sort and send the relevant commands over the wifi network (still working on that).

The camera requirement seems ok, as does the range sensor (the HC-SR04 seems to fit the bill) but I dont know the best way to control the motor and servo or if there is space to plug it all together or if I may be barking up the wrong tree using the PI Zero (W)

Can you give me some clues with regards the servo/motor control and if there is enough space to fit the modules together.

Thanks

Jools


#2

Depending on what the car is, and how much of an accident it had, there might be existing motor/servo control you could tap into. You should pull it apart and post some pictures of the PCB and the internal space so we know what there is to work with.

Servos can use either a hardware driver, or some software on the Pi called ServoBlaster combined with a PWM-capable pin. They just need the one pin, power and ground connections.

Our Explorer pHAT board might be what you’re looking for, but uses the Pi’s 5v power supply for motors- whereas you might need something beefier!

As for power, you can either use a USB battery pack- which will be cheap and have its own charging circuit built right in- or an AA/9v battery and regulator to power the Pi, or a combination of batteries for the motors and a separate supply for the Pi. Which one you use will depend on space constraints, and what sort of battery the RC car took in the first place since you could re-use the existing battery compartment.


#3

This is the pic of the car, the ruler is for the scale so you can see its not big. It basically got crushed so I had to cut the sharp bits off the top. I'm not fussed with the looks of the finished article :-)

The motor for the rear wheels was intact but the front wheels took a bit of damage. There was some sort of solenoid type thing moving the wheels but it was in bits as was the original pcb for the receiver.

There is a slot for 3 AA batteries underneath, I dont think that would be upto powering the PI and other bits but may be useful for the motor . I need to look for a small servo and rig it to the front wheels if possible.

I was looking at the explorer pHAT and fortunately the Pi Zero W has been released which means I dont need to look at separate WIFI dongles.

Is there space to use the Pi Zero W, Explorer pHAT, camera and range finder or will the Explorer get in the way of the other modules? Its difficult to get an idea of how this fits together hardware wise.

If you have any thoughts/ideas they will be truly appreciated.


#4

I am working on a kind of similar project and trying to get ServoBlaster installed, but I have failed. I have googled servoblaster on many sites and tried to follow installlation procedures. Still no luck to get servos to move using arrow keys. My application is controlling a speedboat UP/Downkeys for speed, L/R for rudder control. Doing sudo ./servod I get a listing of GPIO-pins. Apparently I do something wrong. What is the simpliest way to get control of two servos ? All my installations trials are based on RPi3B running Full Stretch 2017-11-29. Do I need any special ServoBlaster for this ?
Asking for advice.
Thanx a lot
calleblyh


#5

Additional info:
For testing purpose I am using PanTiltHat on top of my RPi3B. pantilt.py from tuckershannon and when running python pantilt.py I do get camerapreview and I can see left right up down on the screen, but servos are not moving and I get an error /dev/servoblaster Permission denied. So I assume something is wrong when reading in pantilt.py “#activating servo blaster (servod must be in the same folder as this script!)”. BTW which GPIO-pins control servos in pantilthat ? Which is the correct way to install ServoBlaster? I think on this point I screwed it up. Please advice…
Thanx


#6

sudo ./servod will, by default, set up a series of servos on various pins, which is probably the list you’re seeing.

It runs in the background and creates a filesystem node that you then need to write to, to control the servos.

See the readme at https://github.com/richardghirst/PiBits/tree/master/ServoBlaster for details on how to use it.