Have you tested the new 4.14 kernel?


#1

I mean, I should probably just go ahead and test it myself, and it SHOULD be all good, but wondering if you tested already, with your products. Specifically in my case a Display-o-tron HAT. Ref.: https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=197689


#2

I haven’t yet, as it happens! Thank you for the heads up, I’ll have to update an image with rpi-update and see what works/doesn’t.

Generally I expect everything using a standard interface in an expected way to be fine- so I2C, SPI and GPIO will, with any luck, just continue to function without any changes. That covers pretty much all of our boards. Where I’d expect problems are with things like Unicorn HAT which does some weird DMA-into-PWM-hardware trickery in order to get the protocol timings right.

Where there might be GPIO issues is with the newer 4.14 kernel being incompatible with RPI.GPIO, or any of the other underlying libraries we use. It could also cause problems with the SMBus python library.

Fortunately (insofar as you can call it fortune) I’ve weathered a couple of major OS/Kernel changes over the last few years, so I don’t anticipate any major disasters ;D

Again, thanks for the heads up! I’ve been so busy with other things that this is actually the first I’ve heard of this.


#3

Cheers, and happy testing.


#4

I did my first “rpi-update” ever and all went well. A couple quick auto-reboots and I was back to a Familiar desktop with everything working. Or so I thought.

I have the following at the end of my /etc/rc.local

python /home/pi/bin/piglow-cpu.py &
exit 0

This worked well on this very RPi3 before the update. And my PiGlow beat along to its own drummer while I hacked away.

After the update … CODE BLUE! NO PULSE.

The code works and the PiGlow works because I can test it successfully this way

pi@raspberry $ python /home/pi/bin/piglow-cpu.py &

and away it goes…

Why is it suddenly no longer working at boot time?

My rc.local IS being run at boot as the other 2 lines DO work at boot time

echo heartbeat > /sys/class/leds/led0/trigger
iwconfig wlan0 power off

Anyone have any ideas why?


#5

rpi-update is not the traditional method of updating, and should not be used for any purpose. Any bugs in an unreleased kernel and modules may be transient, and so it’s a complete waste of time trying to fix them.

You should just return your system to the latest officially released kernel, and wait for an update to ship via apt:

sudo apt-get update
sudo apt-get install --reinstall libraspberrypi0 libraspberrypi-{bin,dev,doc} raspberrypi-bootloader
sudo reboot

I can’t stress this enough for anyone else who might see a “new kernel” topic and get curious; rpi-update is not an update utility. Don’t run it. Updates will come when they are released via “apt update && at upgrade”.


#6

I reverted back as you suggested and the problem still exists. So, using ‘dd’, I reimaged the SD to my previous setup and edited rc.local as I had done before to fix the wifi sleep issue.

Here is what I found out!

# MY /etc/rc.local NOW!
# Disable if PiGlow is installed
iwconfig wlan0 power off   <-THE OFFENDING COMMAND

And instead try this in /etc/network/interfaces
Underneath: wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

wireless-power off

So the problem was a conflict between the PiGlow python script and the Power Management command both in rc.local at the same time. And the Kernel version was not the issue.

I thought that I should post this followup to correct my misunderstanding. My Apologies!


#7

Thank you for following up! It’s appreciated.