The Venerable PiGlow, Buster Problems?

Not sure if there should be a Raspbian Buster thread perhaps? But I’m trying to use PiGlow on the latest Raspbian (fresh install, Raspbian Buster Lite, Minimal image based on Debian Buster, Version: **June 2019**, Release date: **2019-06-20**) and it doesn’t seem to be working - any ideas how I can debug and check that the I2C is working, see the logs besides Python, which doesn’t seem to have any indication of a problem.

Symptoms are that it doesn’t light up, despite turning up the brightness, I’ve turned on I2C both using sudo raspi-config and the installation script from the PiGlow GitHub (done using the curl option). It worked on the previous version of Raspbian?

Pi 3 or Pi 4? I ask because there was a big update to the Pi 4’s GPIO. Many many more alternate functions for the GPIO pins. That may be messing things up even if its a Pi 3.
I get the feeling they rushed the release of Buster a bit because it would have meant delaying the Pi 4 release if they waited on some fixes / changes. Thats what it seems like based on posts on the Pi foundation forum anyway. I’m not complaining per say, thats how things go some times.
I haven’t upgraded any of my Pi’s to Buster yet. I’m only going to run it on my Pi 4B when it arrives next week some time. I’m going to wait for the dust to settle a bit first.

It should be that in order for 12c to work raspi-config is sufficient, and anything attached to the normal 2 i2c pins will work if programmed correctly and with the corrrect dependencies installed.

Have you tried to see if the PiGlow has an address when you do a “i2cdetect -y 1”, or if you are running a python script to use the PiGlow (don’t know much about that product’s examples) - does it throw an error when you try to run the script referring to a module being missing ?

One would assume it should just work. Good call to run i2c detect. I should have thought of that, some days its hard to get this old brain in gear.

Careful- the sn3218 on PiGlow is write-only so it doesn’t respond to i2cdetect -y 1 IIRC you need i2cdetect -q 1 instead, which attempts a write to register 0 on every address.