Piglow - irritatingly won't work on any Pi!


#1

I’ve spent this afternoon trying to get my Piglow to work on two RasPis (B and B+), both have same problem! This is the error I got with the Pi B+

I’ve been following the instructions on how to set up PiGlow from Raspberry Pi Resources.
After wget http://goo.gl/18fwzn -O test.py --no-check-certificate

I tried to test the file by running sudo python test.py but…this is the error message I got:

Traceback (most recent call last):
File “test.py”, line 18, in
pyglow = PyGlow()
File “/home/pi/pyglow/PyGlow.py”, line 117, in_init_
self.bus = SMBus(i2c_bus)
IOError: [Errno 2] No such file or directory

The Pyglow files have downloaded to the Pyglow folder I made and all seems to be in order.

DECIDED TO CHECK THE i2c DRIVER MODULE, SO FOLLOWED INSTRUCTIONS FOR THIS.
Added the two lines

THEN CHECKED BLACKLIST CONFIG
sudo nano /etc/modprobe-d/raspi-blacklist.conf
but the file is blank like it’s new, no lines to comment out?

I’ve checked and re-checked that I’m typing the correct thing and cross-checked with the instructions on the Pimoroni website too.

Can anyone help please?
Eternal gratitude guaranteed :o)
Thanks
Sue


PiGlow on Raspberry PI 2
#2

Hi

I would follow the installation instructions on the webpage link below.

Have a go through that and see what happens. Let us know the outcome .


#3

It looks like you’re most of the way there- it’s just getting that pesky i2c enabled that’s the problem! You can try our super-duper enabler script which might help. Type this into LXTerminal/command line:

curl get.pimoroni.com/i2c | bash

And to verify that it’s worked, try:

ls /dev/i2c*

And see what comes up!


#4

Hi,
Thanks for the replies.
I’m not sure exactly what worked but …the PiGlow is now operational!!

Having worked through the instructions from tigerfrost I got a similar problem to my original one but then I tried the suggestion of gadgetold and hey presto it’s now glowing away!

Thanks so much for the help
Sue


#5

Huzzah! Glad to hear it’s sorted Sue :-)


#6

Hey thanks ‘gadgetoid’.

I had the identical problem as the o.p. with the PyGlow I bought at the RPi Bday Bash yesterday.

Your solution worked perfectly for me.

ThanQ
Mark


#7

Ah, I will give this a go myself as have found that the PiGlow is a little hit and miss since updates to Raspbian etc. I did a fresh install with the 03/05/15 Raspbian image yesterday and struggled to get the PiGlow working properly - I have done it plenty of times before, and now seem to see that the older instructions I followed were not working for some reason.

I managed to get three of the four basic examples included in the https://github.com/pimoroni/piglow setup guide (legs.py doesn’t work for some reason, and neither do any in the boeeerb folder), so there must be something not quite right.

I’m going to have a go from fresh again, but follow the above install script to see if that makes installation any simpler.


#8

This is my fault- there’s currently a discrepancy between the code examples and the library published to Pip as I only recently ( yesterday in fact ) changed a whole lot of stuff to make the library less bonkers.

So, yes, right now the examples probably wont work! D’oh. I’ll get the new version pushed up now, I’m pretty sure it’s stable enough.


#9

Ah, there we are then! Looking forward to getting the updated version once you’ve had chance to sort it then.

I’m actually trying to use the PiGlow as a mood lamp, as per your guide (http://pi.gadgetoid.com/article/making-a-piglow-remote) as my PiGlow is now a little redundant since I managed to get the DOT3K working as a system monitor.

With that in mind, I may drop you a line if I get stuck anywhere if that’s okay!?


#10

Aaaannnnnddd. done! Try:

sudo pip install -I piglow

( Oh and yes, you can drop me a line… also I suspect that article will be a liiitle out of date but not hard to adapt! )


#11

That was quick! Excellent, I’ll give it a go later then hopefully (although my new NAS drive arrived today so I’ll probably be setting that up later this evening, then updating my various Pi’s to find the new share - should be straight forward I hope!).

Thanks Phil!


#12

You’re welcome. I made a mental note to do it yesterday, but my head is groggier than a pirate’s cellar this morning. I need to just start pushing libraries out as and when I update them, and worry about stuff going wrong when someone reports it.

Which reminds me… Explorer HAT!


#13

Too much rum then?

No problem - it sounds like an endless task at the moment, but also exciting for us mere mortals who would be lost without the help!


#14

I wish! I think I brought a cold back from Norwich and didn’t catch it early enough to stave it off with ludicrous levels of honey consumption. The last time one threatened I ate more than half a jar… I may be Winnie The Pooh…


#15

Ah, never good!

You know, you might be able to get rum infused with honey…


#16

with that much honey in a single body I would raise the possibility that you should have written ‘winning the’… ah, forget it :D


#17

Aaaaaannnnnddd. Updated my end. It works! Thanks!