PiGlow problem (Buster fix)

I did a clean install of Buster (the “Raspbian Buster with desktop” version) on a Zero 1.3 with the intention of using a PiGlow.

The problems started when I tried to run the example python scripts.
Using Thonny Python IDE I just got errors. The same happened when I tried typing in the command in a terminal window.

I then hit on the idea of trying to see if running them in the Python 3 IDLE worked. This had to be installed as it is not included with Raspbian Buster with desktop. The Pyglow worked just fine. All of the examples worked. They also started working when using Thonny*.and the terminal! Happy days!!

Now this poses a question do you need to install the Python 3 IDLE if you are using the “Raspbian Buster with desktop and recommended software” (and Buster lite)?

Based on this thread The Venerable PiGlow, Buster Problems? I suspect that Buster Lite also requires Python 3 to be installed separately for PiGlow to work.

Perhaps gadgetoid could tell us how to install Python 3 using the terminal.


*Blimey Thonny is a bit slow!

I believe you run
sudo apt-get install idle
from the terminal window