Having trouble with PicoW and Inky Pack


I am having problems with gettin my Inky Pack to work with my PicoW.

I am using Thonny
I have used the file pimoroni-picow-v1.19.10-micropython.uf2
I have copied files from pimoroni-pico to the PicoW, and have the lib folder, the files there, as well as network_manager.py and WIFI_config.py
I have tried to install micropython-urllib, but I am having problems.
This is the error message:


I have been able to get clock.py to run successfully

When I try to get placekitten.py to run, I get an error:

Traceback (most recent call last):
File “”, line 2, in
File “network_manager.py”, line 2, in
ImportError: no module named ‘network’

What I doing wrong?

I’m getting the same error when I try and install this library - I think there are some changes happening with MicroPython package management at the moment (moving from the old upip system to a new one called mip) which might be why it’s not working properly?

There’s a compiled version of the urllib library here: pimoroni-pico/micropython/examples/common at main · pimoroni/pimoroni-pico · GitHub - I generally just copy the whole lib folder to my Pico using Thonny.

Thanks for the reply. I download the whole repository, and tried again. Still no luck

Hmmm - are you sure you’re running the correct version of MicroPython? Mine is letting me import network fine.

Here’s a direct link to the most recent Pico W build!

Thanks, it seems I had downloaded the wrong file. It now works,

1 Like