Hyperpixel 4.0 Screen not working on Pi 2

I am trying to get my Hyperpixel 4.0 screen up and running on my Raspberry pi 2 Model B V1.1 2014. I have recently installed a fresh version of Raspberry Pi OS from the desktop installer. I plugged my Pi up to an ethernet and ran the Curl command from this github page:

The install seem to go through smoothly. And I checked all the boxes for Rectangle display, pi3+ or older. However when I rebooted the pi, only the backlight would come on, and showed nothing at all on the display.

I then tried running through the installation on this github page:

Still had no errors and everything seemed to install correctly. However I was just met to a blank backlit screen upon load up.

Any help would be greatly appreciated!


Might want to give the Legacy Buster OS option a try?

Thank you! That worked like a charm

There were some big changes in Bullseye that messed things up for the Hyperpixel installer. Phil Howard is working on a solution, might take a little time though.
On the plus side Buster works just fine.