Hyperpixel 4 doesn't work on Rasp Pi 3b+ nor my Rasp Zero W - screen doesn't power up at all

I installed the Hyperpixel 4 on both units, reflashed using both raspbian full and raspbian lite. Followed the instructions here : https://learn.pimoroni.com/tutorial/sandyj/getting-started-with-hyperpixel-4

nothing on my hyperpixel when it reboots. not even a backlight. able to ssh into both units.

do i have a defective hyperpixel? spent almost 8 hours today following the basic instructions and it’s not working.

I have to ask the obvious, firmly attached to the Pi’s GPIO?

yes. all the way in and solidly bolted on my rasp pi.

Are you running Buster? Buster seems to have some quirks that mess with things. You can get Stretch here if need be, for testing purposes. It should tell you if its hardware or software. If it works you know its a Buster issue, if it still doesn’t work its more than likely defective.

Are you running Buster? Buster seems to have some quirks that mess with things.


Just tried again - reinstalled with Stretch. Ran through the listed process - nothing. hyperpixel-init works though when I am ssh-ed into pi. Rebooted and still no image.

Am I supposed to have some kind of backlight? Apparently there’s supposed to be have some backlight regardless and I don’t have any on my case…

Just so you know I don’t own a hyperpixel. There are a few here on the forums that do though. I would think the backlight should be on regardless of anything else?
One option is to go here
And send them an e-mail witha link to this thread.