HyperPixel 3.5 and Pi4 Not work


HyperPixel 3.5 display not working lastest version Raspbian Buster and Raspberry Pi 4.
Try it clean OS, and installing command: “curl https://get.pimoroni.com/hyperpixel | bash” .
Then there is nothing on the display after restart :(
Please help me.


Looks like you ran the correct installer. The installer may not work with Buster?
You could try the manual setup listed here,

Then see if it throws up an error along the way to tip you off to what went wrong.

Do you have an HDMI display plugged in, and is that working? If yes go to where you select displays and see if the Hyperpixel is listed. The Pi 4 can do multi monitor and has a new GUI for setting it up.
I haven’t run Buster yet or I would point you to where it is.

I also tried manual installation, the same result, does not work.
On reboot, there is a signal on HDMI.
Hyperpixel is black, just backlight.
App Menu -> Settings Screen configuration -> Screen Layout Editor -> show DSI-1 and HDMI-1.

It’s not well communicated yet, but you need the files from the Pi 4 branch of the GitHub repository - https://github.com/pimoroni/hyperpixel/tree/pi4

In your case it will almost certainly be the old /usr/bin/hyperpixel-init which doesn’t support Pi4.