Original HyperPixel display on Pi 4


I have the original Hyperpixel display running fine on an old Pi. I figured I’d try and use it on my Pi 4 and found this page (https://github.com/pimoroni/hyperpixel/tree/pi4). I ran the installer on a newly formatted, latest build of Raspbian and all I get after the reboot is a black screen on the HyperPixel. Where should I start looking to fix this please?


So I just had this issue, but did a clean install of the latest Raspbian full, did a full sudo apt-get update && sudo apt-get upgrade update, and suddently it works. It seems that for some reason it occasinoally doesn’t stick.

Which option did you select at the installer prompt?

Hi- thanks for your feedback. I don’t remember there being any options during install. I’ll give it another go as you suggest. Cheers

Which install method did you use? If you use the curl https://get.pimoroni.com/hyperpixel | bash method it should ask you which combination of Pi and Hyperpixel board you have.

Oh yes, I remember now :) Yes, I told it I had the original HyperPixel and a Pi 4. I will try again tonight and report back. Thanks Again.

@Shoe I just tried it again. Fresh SD card, fresh install of the latest full Raspbian, fully updated and upgraded. Ran the curl command, agreed to proceed when alerted to the fact that the software was for the old, original HyperPixel (which I have). The only other thing I was asked was to reboot at the end which I did. Nothing on screen. I can see the Pi booting due to LED activity. Also if I re-plug-in the HDMI I get an upside down and horizontally-flipped desktop picture and I can see the mouse on my main monitor. Still nothing on the LCD :/

That souds very similar to the issue reported here, which Phil seems to be trying to work on. A fix might take some time unfortunately.

OK, thanks. I’ll keep an eye on that thread,