HyperPixel 4 totally blank

Purchased a hyperpixel 4 in the pi brick and mortar store today. Just gotten it home, tried it on a pi 0, pi 3 and a pi 4, all with their own SD cards (no sharing image between each other), all latest debian buster.
All of them I installed via curl https://get.pimoroni.com/hyperpixel4 | bash and choosing the relevant option, rebooted the pi, completely blank display. The backlight turns on, but it never displays any image. Any fix or do I have to take it back to the store? I figure 3 pi’s all failing having followed website is a bad sign.
The pi 4 I also tried making a new SD card from scratch and running 'git clone https://github.com/pimoroni/hyperpixel4 -b pi4` and running install.sh, which appeared to modify the stock config.txt, but same result of blank screen

anyone? I’m quite lost for answers here

Did you solve your issue?
I had the similar issue except that I didn’t even get the backlight.

A little late to the topic but I find myself in the same situation. Hellooooo Pimoroni can you hear us?