Hyperpixel sleep setting

From what I understand, the Hyperpixel can be configured to go to sleep and wake up on touch. I have the following configuration:

Raspberry 4
OctoPrint running from OctoPi image distro
Hyperpixel 4
OctoScreen (being displayed on the Hyperpixel)

I have everything set up and working, however the display never goes to sleep, and I’d like the display to go to sleep after 5 or 10 minutes of inactivity, and wake when it is touched. From what I understand, this is a Hyperpixel setting, not an OctoScreen setting.

I read the Disabling Power Save section (https://github.com/pimoroni/hyperpixel), thinking I would do the opposite (since I want to ENable power save), but this hasn’t panned out. Here is a running commentary:

To prevent console blanking (framebuffer/text console), edit /etc/kbd/config

/etc/kbd/config doesn’t exist

append consoleblank=0 to the boot command in /boot/cmdline.txt

I added consoleblank to cmdline.txt, and it is now:

console=serial0,115200 console=tty1 root=PARTUUID=6c586e13-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait consoleblank=60

…but the screen didn’t go to sleep.

To prevent X11 sessions from making your HyperPixel sleepy (DPMS power saving), add this line to /etc/xdg/lxsession/LXDE/autostart:

/etc/xdg/lxsession/LXDE/autostart doesn’t exist

So I’m kinda at a loss and thought I’d reach out for some help on how do I enable sleeping the display.

Thanks,

Jeff

^bump. It’s been 15 days since I posted this. Can someone from support take a look and post a reply?

Thanks,

Jeff