I2C device not detected on pi


#1

Hi everyone,
I have a pi zero that I am connecting to a Pimoroni drum hat, and I need it to communicate over I2C.

I followed the steps here but when I run
sudo i2cdetect -y 1
the grid is filled with dashes and there is no I2C device detected.

I used a multimeter to check the connection from the drum hat to the pi, and they are all fine so it isn’t anything mechanical. What else might be wrong and causing the pi to not find the hat over I2C?

Thanks for any help.


#2

Hi! Just to cover all the bases, you’ve soldered the header onto the Pi Zero? Could you also try running curl https://get.pimoroni.com/i2c | bash in the terminal, please?


#3

I do have it soldered, but I think that is my issue. It seems that one of the pins is soldered fine to the hat, but not to the pi. When I continuity tested, I put the multimeter on the pi’s header (not on the pi itself), which would explain why it was continuous and I thought it was ok.

I am going to try resoldering it and I’ll update whether this works.


Drum Hat doesn't detect hits on Pi Zero, but works fine on older Pi
#4

Resoldering worked, and I2C is detected! Now I’m just having difficulties with the drum hat, see this thread.