Automation Hat - i2cdetect -y 1


#1

I’ve just installed my automation hat and enabled I2C support on the pi 3 using raspi-config. As I’m not intending to use python but rather write my own code in C I haven’t run the pimoroni install scripts.

I ran i2cdetect -y 1 and the output correctly showed a device at 0x48 (I understand that this is the ADC). Having read the pin out information I believe that the three LEDs are driven from an SN3218A device which is located on the I2C bus at 0x54. Should I be seeing this reported with the i2cdetect command?

I’ve not tried sending any I2C commands yet but simple gpio commands using pigpiod correctly toggle the relays and open collector outputs so I believe the board to be working.

Any assistance gratefully received.

Cliff


#2

I don’t think so because the sn3218 is write only.


#3

Thanks for the reply. After more reading I came to the same conclusion that as the device is write only a non invasive read command won’t elicit a response.

I re-ran the i2cdetect command with the -q flag (use SMBus “quick write”) added and the device did show up.