Import plasma gives error

I have the Pimoroni Plasma2040 module and tried the example for controlling the WS2812 lights. It falls at the first hurdle with the line import plasma, which generates to error ‘no module named plasma’.

I refreshed the chip with the latest firmware along with the previous two versions and all gave the same error.

Can anyone tell me what I am missing as I thought that theses modules were baked-in with the Pimoroni micropython.

What uf2 did you flash it with?
I ask because its showing cosmic_unicorn v1.21.0 in your screen shot?
I do believe the one you want is,
If you have the Plasma Stick, Pico W onboard version.

Thanks for the info. I’ll give it a try.

Thanks, that was the fix. I do find it confusing though that there doesn’t seem to be a master document clarifying what firmware is needed for which modules, unless I am missing something. Having funky names is all very well for giggles, but it doesn’t really help with clarity.

It could be better, info wise, as to what image to use.
I look to see if said device has a specific name matching custom image. If it does, I use that uf2. If not I go with the Pico or Pico W image. Pico if it only has an RP2040, and Pico W if its a Pico W onboard.

Sounds like you’re sorted now, but should anyone else run into this post in the future there’s a list of what MicroPython builds go with which boards here:

Looks like I need to add PicoVision to that list…