Wireless plasma kit problems

i’ve been given one of the wireless plasma kits for Christmas. The one with the star shaped bottle. Unfortunately i seem to be having some issues with it all. I will explain the sorry tale here:

  1. i started off ok and got everything ready and plugged the plasma stick 2040 into my Raspberry Pi 4. Lights showed up and everything seemed to work ok. I tried a few things with changing the colours of the lights and all was well.
  2. I then tried to set my wifi configuration up. In hindsight, I seem to have put the wrong country code in. The result was that, while I still got lots of flashing lights Thonny had frozen and i couldn’t seem to break out of the main.py loop. I was getting ‘device busy’ messages all the time.
  3. I got to the point where i thought i needed to reflash the uf2 file and start from scratch. There was a link on the pimoroni website for where all the code examples were, so my intention was to reflash the 2040/Pico and copy the code from this link https://github.com/pimoroni/pimoroni-pico/tree/main/micropython/examples/plasma_stick
  4. So, i have tried reflashing with the image from this link https://micropython.org/download/rp2-pico-w/rp2-pico-w-latest.uf2 however, this does not work. When i connect to Thonny and try and open up something on the Pico all i get is a ‘device busy’ message.
    I can’t quite believe i have got myself into this situation, as it all looks so simple. I assume that i have got the wrong image to copy over onto the plasma stick/Pico. If anyone could point me to the right location for the necessary image that would be great.

There is a flash_nuke.uf2 file that will erase everything. Dropping other uf2 files doesn’t always do that.
Raspberry Pi Documentation - Raspberry Pi Pico and Pico W

The Pico will show up back up again as RPI_RP2, in Boot Mode, then you drop the Pimoroni uf2 file to it.

thanks for the reply. I’ve downloaded and copied over the flash_nuke version, when the pico reboots it comes up with the file system again i.e. it boots up as a mass storage device. I’m not sure if that is what is supposed to happen or not. Anyway, i copied over the pico-w uf2 file i referenced above and the same thing happens i.e. ‘device busy’.


You’ll need our custom version of MicroPython, not the generic one - try the most recent one from here: Releases · pimoroni/pimoroni-pico · GitHub - you’ll want the ‘picow’ one for Plasma Stick. Here’s a direct link!

hmmm, thanks, but i’ve just tried using that and once again when i try Thonny i get ‘device busy’. It seems to recognise that i have a pico connected, as when i try and load/save anything in Thonny i get an option for either ‘this computer’ or ‘raspberry pi pico’


Hmm - what happens when you click the stop button in Thonny to interrupt what the Pico is doing?

Not much i’m afraid. It doesn’t seem to have any effect, i still get the ‘device busy’ message

Success!!! I thought i’d try it out on my Windows laptop, rather than on my RPi 4, i have Thonny installed on there as well. It seems to be able to recognise that it’s there now. I’ve downloaded some of the examples on the Github page and i now have flashing lights.
Just by way of checking though, i assume that it’s best to only use the name ‘main.py’ once i’ve tested everything and it’s all working ok?

Woo - glad to hear you got it talking again.

Yes, best to test your code is working OK before saving as main.py, otherwise you can end up having to flash_nuke and losing your code - I’ve done that a few times!

Great, thanks for your help

It’s usually the other way around for me, my Windows PC is the one that gives me issues connecting. For me, my RGB Keypad running Circuit Python mucks things up. If I unplug it when tinkering with an RP2040 running Micro Python, next to no issues.

@cappers Is your Pi 400 running the latest version of Pi OS, and fully updated. Correct Interpreter set, (lower right hand corner) ?