Wireless Plasma Kit Issues

Hi,

First time playing with Raspberry Pi things and purchased the Wireless Plasma Kit. Having a bit of a nightmare, to be honest!

Got it connected to my Mac and have Thonny installed. Lights did nothing, however, so double and triple checked the connectors - all looked good. Noticed in Thonny that nothing was showing up on the Pico (empty directory), so after some rooting around decided (rightly or wrongly!) that as I wasn’t sure what state the board was in as it had none of the files the assembly guide said should be there, that I’d nuke it with flash_nuke.uf2 and then install pimoroni-picow-v1.19.12-micropython.uf2

All seemed to go well, created a WIFI_CONFIG.py and then tried one of the example files from the plasma stick examples (Alternating Blinkies). However, when I try to run it execution seems to hang at the following line:

led_strip = plasma.WS2812(NUM_LEDS, 0, 0, plasma_stick.DAT, color_order=plasma.COLOR_ORDER_RGB)

Narrowed it down to that line by forcing execution to stop after each line until I got to the one that caused it. If I try to Stop it in Thonny, the device just disappears and I have to unplug it and plug it back in to get it to show again. Clueless what the problem might be.

I did try another example but that required wifi network and the package NetworkManager doesn’t exist, and I haven’t got a clue where to start with installing that.

Any help appreciated, I’m out of ideas now!

Thanks,

Gareth

Hey there - sorry to hear that your Plasma Stick missed the preloading step. Did the bag it came in have a little round sticker with a batch number on - if you let me know the colour and the number I’ll let production know.

It sounds like you’ve found the correct version of MicroPython - and you can find the Plasma Stick examples here: pimoroni-pico/micropython/examples/plasma_stick at main · pimoroni/pimoroni-pico · GitHub .

network_manager.py and WIFI_CONFIG.py can be found in the common directory here: pimoroni-pico/micropython/examples/common at main · pimoroni/pimoroni-pico · GitHub . If you click the green code button on the front page of the repo there’s a ‘download zip’ option that will let you download the whole repo, you can then transfer all the examples at once using Thonny’s ‘files’ window rather than having to copy them one by one.

I don’t have a Mac so will probably of limited use troubleshooting your connection issues but it sounds like the USB device is crashing if it needs a restart. If it’s an older Mac it might be worth checking that the USB port you’re using is capable of supplying enough current for the whole string of LEDs - you could try changing ‘NUM_LEDS’ to 1 or 10 to see if it works with fewer LEDs (and less current)?

Oh - wait a sec, just tried v1.19.12 and it’s locking up for me as well. Try v1.19.11?

Really appreciate the help, hel. Put 1.19.11 on and all working as expected! Thanks also for the link to the network_manager.py file as well, fantastic.

Thanks again, Gareth

1 Like

I had the same issue trying to upgrade a Plasma Stick 2040 with pimoroni-picow-v1.19.12-micropython.uf2. Using pimoroni-picow-v1.19.11-micropython.uf2 worked as others have said. I couldn’t even get as far as the COM port connecting with 1.19.12.

Strangely 1.19.11 reports it’s version as :-

import os
os.uname()
(sysname=‘rp2’, nodename=‘rp2’, release=‘1.19.1’, version=‘9dfabcd on 2022-12-21 (GNU 9.2.1 MinSizeRel)’, machine=‘Raspberry Pi Pico W with RP2040’)

I would have expected it to show release=1.19.11?

Happy to report we’ve tracked down and fixed this bug so the next release should work with Plasma again :)

I think the release number reported by os is the MicroPython release that our customised version is built upon - the last official release was v1.19.1 back in June. We’ve incorporated a bunch of prerelease patches and upgrades since then though!

I’m not sure if its related but 1.19.12 also locked up my Galactic Unicorn. If totally locked up / froze and I had to flash_nuke it and go back to 1.19.11. Pressing reset just got me another lock up on boot up. Couldn’t connect with Thonny either so no way to delete the main.py file

@alphanumeric Just tried v1.19.12 on my Galactic Unicorn with the launcher examples and it seems to be working OK for me - but drop us a Github issue with the details if you’re having trouble!

The eighties_super_computer.py was what locked up for me.
I’ll flash nuke it and have another try. If I get the same lockup I’ll post it as an issue on github.

1 Like