Inky wHAT Issues

I have recently purchased an Inky wHAT (yellow), I’ve connected it to a Raspberry Pi Zero W (on a fresh Raspbian -Buster-Lite image, followed the instructions as per the tutorial
, once that finishes I run the examples I get no errors but literally nothing happens on the display. I have tried a different raspberry pi zero with and have the exact same result. I’ve flashed the SD, installed again but exactly the same thing nothing. The example I am using is python --type “what” --colour “yellow” --name “Inigo Montoya”.

I have tried python3 : python3 --type “what” --colour “yellow” --name “Inigo Montoya”. But again nothing at all.

During the one line install I do get the errors Unable to locate package xxxx
Apt failed to install xxxx then it says falling back on pypi and then downloadsthe approriate packages, so perhaps this is ok? The below is an example output:
E: Unable to locate package python-fonts
Apt failed to install python-fonts!
Falling back on pypi…
Looking in indexes:,
Collecting fonts
Downloading fonts-0.0.3-py2-none-any.whl
Installing collected packages: fonts
Successfully installed fonts-0.0.3

Any suggestions?

I had a similar experience a few weeks ago trying to use a Red inky what on a Pi A+.
All the same complaints during installation and no function when finished.

The installer was supposed to enable I2C or SPI (can’t remember which) but checking the Raspberry Pi Configuration screen neither were set. So I set SPI and I2C to enabled in the Pi Config then rebooted.

When it restarted I found all the examples worked properly…

It may be a Buster issue. The Lite version may be missing something you need to make the inky work fully. I’d try the Buster with desktop version. Once you have everything working go into Raspberry Pi Configuration and set it to boot to command line instead of the Desktop GUI. It will be almost as good as running the Lite version.
If that fails to work, as a temporary solution you could try Stretch instead of Buster.
You can get the older versions of Raspbian here.

Thanks. I had read somewhere about enabling I2C SPI using rasp-config but tried that already and rebooted but just the same :(

The Pimoroni Bash one line installers should do that for you. The manual install methods listed on GitHub etc will require you to turn them on via Raspberry Pi Config.
If you haven’t already try sudo pip3 install inky

I tried the pip install inky too thanks. How can I tell if the Inky connection is ok, maybe something is faulty??

Good idea on the different version of Raspbian, I’mgiving stretch a go now

Yes but did you try pip3 instead of pip?
pip3 installs for python 3 and pip for python 2.

Yes tried pip3 that didnt work either. Ran out of time trying older OS, I hope its not a fault.

currently trying to install things manually using python virtual environment to see if that helps

Something I just thought of, will the display update if the pi is plugged into usb port of laptop? Could try from powering it from mains.

If you are powering your Pi via a PC USB port that could be an issue. USB 2 ports ae limited to a max of 500 ma. Thats more than enough to drive a PI Zero, might not be enough current to supply the display too though.

Tried different power options and unfortunately nothing worked. Likely to be a fault.

The only other thing I can think of is to make sure the inky is firmly attached to the Pi’s GPIO. You will have to press down firmly to get the pins to go into the female header on the inky. Don’t press on the screen though, press on the edges of the circuit board.

Thanks. Tried pushing it in well. Still no success :(

You could e-mail Pimoroni via the following link. And see what they say. Put a link to this thread in that e-mail.

Hello there. I was seeing similar. But would be very interested to know what you are getting out to the console when you run the examples - ot is it genuinely nothing?
I was seeing the same issues when curl |bash install - but the key parts are installed without issue - a pip3 install inky states everything is already satisfied. Best.
Power is a suitably high power feed. Pi is B+ v1.2. OS is full 2019-09-26-raspbian-buster-full that has been updated and is running in The network connection is wired.
I was concerned about how far the ribbon on the back was inserted into the terminator (as there was no slack) - however, manually setting raspi-config to enable SPI and I2C and then restarting appears to have resolved the issue (for me).

Unrelated, but what is an “Inky wHAT”? Is it a typo for the Inky pHAT? My forum name (without the “72”) has been my IRL nickname for the last 40+ years.

It’s the bigger Inky “wide-HAT” version of the inky pHAT.

1 Like