Installed Onoffshim but where has Kodi gone?

I attempted to install the onoffshim on rpi4 but discovered the 3Amp power plug doesn’t fit. An rpi3 2Amp socket fitted, but didn’t supply enough power.
Uninstalled everything, only to discover the link to Kodi no longer works.

Is there anything I can do to remove the onoffshim software & get Kodi back?

What else do you have connected to your Pi 4B? I ask because I ran my first 4B from the Pi 3 2.5A PS with a USB C adapter, with no issues. The official Pi 4 Power Supplies were out of stock when I ordered my Pi 4B.

Have you tried reinstalling Kodi?

I removed the onoffshim so all that’s plugged in are power, HDMI & cat5

It’s almost like the onoffshim software has broken the link to start kodi somehow
Tried installing Kodi again but it says it’s already installed with the latest version.

Is there anything I can do?

So what happened when you tried to power the Pi 4B from the On Off shim?
Did you solder a header onto the on off shim?
How are you starting Kodi and what happens when you do it?
Buster Lite, or Full Buster with desktop?

A) Lightening Bolt top right of screen
B)Yes soldered the shim to a header
C) Kodi is accessed via the rpi menu or a link on the desktop.
D) Screen goes black
E) Full Buster with desktop

I’ve tried everything I can think of. Boots to desktop fine & everything seems to be working except being able to access Kodi

One solution is start over with a fresh install of Buster, then install Kodi.

It’s what I would do as my Linux software skills are noob level at best. Or maybe uninstall just Kodi and reinstall it. I’d have to Google how to do that.

Yeah that’s what I was thinking, just looking for a better option.

Thanks for your help anyway