Iqaudio Codec Zero

Hi I have enabled the dtoverlay in config.txt for this newly purchased hat but arecord -r16000 -fS16-LE test.wav just returns a null and empty wav?

How do you record from mic on this card?

I don’t have one to try but have you tried

No but will try thnx as haven’t really done much but install with the dtoverlay but thought that should of provided something the null wav has me confused as its not zero just empty


Did indeed work so many controls not sure what setting got it but hey thnx :)

Is maybe, the switch to Pulse Audio in PiOS an issue?

Nope the above git hub are just pure alsa states and that fixes it.
Its only the desktop version that has gone Pulseaudio as default and that still lies on top of ALSA

Ok, thanks for the post back. My Linux skills are pretty basic so sometimes its just a stab in the dark until somebody with the right skills comes along. It sounds like you got it working so that’s good. Rock on, lol.