USB Mic not working with Pi Zero W

My new Mini USB Mic from the Pimoroni store (btw thanks! Speedy despatch!) isn’t working with my raspberry pi zero W. Tried doing the arecord -D plughw:1 -f cd /tmp/recording.wav, copied the file over to my laptop to play but it didn’t do anything. It shows up in arecord -l but the file is silent. Tried using alsamixer to up the level but still nothing. I’ve got the mic plugged in to a 3-port USB hub with ethernet and powered by a Sony tablet USB charger (5V 1.5A). I tried plugging it in to my Windows 10 machine but that didn’t work either from settings. You can see it there as a microphone but can’t test it. There’s no light on the mic. Thoughts? Do I have a faulty mic?

Just want to confirm that you went to the Raspberry Pi menu, then Preferences , then Audio Device Settings , and selected USB PnP Sound Device ).

Thanks for getting back to me. Yup, tried that to no avail.

Ok, I don’t own one myself and don’t know what else to look at etc.

Well this is embarrassing. They sent me a 2nd one (thanks Pimoroni!) which appeared not to be working either but my colleague tried it one his workstations and both usb mics are fine. I just didn’t put the volume all the way up! Whoopsies!

Stuff like that happens some times. Been there dome something similar. ;)