Pi Zero W no USB power


#1

Hello community. First time Pi user here. I was so excited to complete my first ever Pi project but I’ve stuck in setup. For some reason, either the usb adaptor or the port itself don’t function properly. I have no power coming to the wired mouse (led indicator off) and as a result I can’t complete the Raspbian setup! I’ve also tried with a usb hub and again led indicator is off.

I don’t really know what to do as I am not able to enter any input data. My keyboard is a Bluetooth one and while I am aware of Bluetooth 4.1 on the new Pi, I am not sure if I can connect it before even I complete the setup stage. Please advice.

Thank you


#2

Not sure what is up with your usb mouse assuming your plugged into the right usb connector on the pi (one is for power, the other for usb devices). If your mouse has and led indicator perhaps your not geting enough power. Be sure you have a quality power supply or try switching out the usb cable your using to power it, although this is usually more a more evident problem in the p3 rather than a pi zero. You might try a powered usb hub as well. If you have another mouse perhaps you can try that, or if you have another pi you can try setting up on that pi first. If all else fails perhaps you can look into a “headless” install, where you use your exisiting computer’s keyboard and mouse over a network connection on your computer, perhaps with a usb to ethernet adapter. If this fails to work then perhaps your usb port on your pi is bad.

I am new to the forum, but if you can, post pictures of your setup as it helps others spot problems.


#3

Hello. I’ve tried another mouse with no result. Alternative usb cable didn’t help either. Do you think it might be my power source? I am using an iPad power adapter, MD836B/A.

I had a look into a “headless” install before but as the new Pi doesn’t come with ethernet port, I need Linux to connect it to the network via WiFi. Something that I don’t have.


#4

When you say you can’t complete the Raspbian setup, do you mean via NOOBS?

You can get the Pi to connect to a wifi network without having to set it up inside Raspbian. Not trivial but you can drop a wpa_supplicant.conf file on the SD card (assuming it has a Raspbian image):

country=GB
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
	ssid="mySSID"
	psk="myPSK"
	key_mgmt=WPA-PSK
}

#5

I am not on Linux though. I can’t see that partition on Mac I think.


#6

you can also access your pi over usb without ethernet with a simple micro usb cable. I doubt the power supply is the issue if your getting power and an alternate mouse is not working. Maybe try this video on pi over usb, there are others but here is one tutorial.


#7

here is another if that one is out of date, there was a link in comments to reddit about issues with that tutorial.


#8

It should just show up as ‘boot’, it does for me in Windows, wasn’t aware of any differences for Mac.

Tho’ if you’re stuck in the NOOBS setup and haven’t got Raspbian installed it probably won’t help. You can always image Raspbian to the SD card directly. Can you provide any more specifics about what was on the card when you started and what you’ve done so far?


#9

To solve your original problem - trying different USB hubs and power supplies could be a fix. The iPad power supply might not be any good (tho I’ve had pi zeroes running on a shoestring before without problems). Can you test the USB hub, or plug something directly into the pi to check its working?

And if those all fail, post a (preferably high resolution close up) picture of the usb ports on the pi zero here so people can spot any defects.

One more thing - are you definitely using the right usb ports for the right things? Power should be on the right hand port with the ports facing down, and usb devices should be connected to the port nearest the HDMI connector. Confusingly, it is possible to power the pi with the other USB, but they aren’t totally interchangeable!


#10

Unfortunately, the only micro-USB cable I have is the adapter came with the project box.

From what other people saying, if the power is OK, it’s either a faulty cable or faulty USB port. My connections are correct. Power cable in the port that says ‘PWR IN’ and USB hub in the port that says USB.

I’ve tried connecting power via USB port and Pi powers up successfully. So, I guess there’s no problem with the port itself


#11

Hmmm. Would seem to be a USB port problem then. Can you post pictures of the top and bottom of the board just to check?

If it is faulty, you’ll have to wait for one of the Pimoroni crew to reply and get you an RMA.

If you’re desperate (and why wouldn’t you be) to get it working, and have a USB cable to sacrifice and a few tools, you could test the USB port: strip a cable until you can see all the four connections inside and the copper inside those wires. Then you can use a multimeter to test the continuity between those wires, and the pads on the back of the board. The two gold pads behind the data USB port go to the USB data wires (probably green/white coloured insulation), and the two behind the power port go to the USB cable’s power wires (usually the red/black ones). If there is continuity, then maybe the problem is with the software or somewhere else on the board.


#12

How do I notify Pimoroni about my issue?


#13

I would guess that tomorrow @gadgetoid or @RogueM will reply and help you out.

Do you have a picture of the top of the board?


#14


#15

Just to check are you using a shim to connect the mouse to the Pi? Is it definitely fitted the right way around?


#16

I am using the micro-USB to USB female adapter came with the Pimoroni project box. And yes, is the right way.


#17

Ah right, yeh you can’t get that one wrong! With the tiny shims it’s definitely possible to get them the wrong way round. Just thought I’d check 🙂


#18

Looks like you’ve narrowed it down to a faulty adaptor- if you haven’t already bunged us an email at support@ then PM me your order number and I’ll get a replacement on its way!


#19

Just to conclude, the micro-USB to USB (female) adapter was faulty. I’ve received a new one from Pimoroni and it works just fine. My new Raspberry Pi is up and running. Thank you.