Getting trouble with my pi zero w USB port


#1

Hi,

First :
I’m a 2 month noob in the raspberry world.
But I have a Raspberry Pi 3 an try things on it.

Last month I bought stuff at Pimoroni’s shop
I received my first Raspberry Pi Zero W.
But when I tried to configure it like I did with my Raspy 3 I had some trouble :

  • the Hdmi output was ok, _but it was impossible to plug the same USB dongle (for a Logitec K400r keybord) as I did on Raspy3.

  • I thought it was my keybord, so I bought an other keyboard “Raspberry compatible” on amazon (EgoIggo Mini Clavier)
    Waiting for the order, I try to connect to my RaspyZW by using auto wifi configuration on boot.

  • It was a success! So now I’m now able to talk to RaspyZW on ssh
    Then I received my new key board, tried it. But the mouse didn’t move an once on RaspyZW but worked on Raspy3.

  • I try few things with GPIO (Blinkt!) but it didn’t work. Maybe my soldering was not good enough. I don’t know.
    Blinkt! works perfectly on Raspy3.

  • Then I tried to install Flotilla Dock. But the process stopped (endless) when it said : plug the dock to continue.
    I tried to plug /unplug it many times, restart, restart the install. But no led came to life on the dock.

Now I suspect clearly that the data USB do not work well.

When I do $ lsusb :
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

When I do $ curl https://get.pimoroni.com/diagnostic | bash

Raspbian GNU/Linux 9 (stretch)
Linux kernel 4.9.41+ on armv6l
Revision match: Pi Zero W Rev 1.1

card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]

No USB devices found...

How can I activate USB?
Maybe you can help me some way?

Thank you


#2

Several Pi Zero W’s here that I often use my Logitech (unifying) keyboards on.
This is the hub I use, https://shop.pimoroni.com/products/three-port-usb-hub-with-ethernet-and-microb-connector
I’ve also used this , https://shop.pimoroni.com/collections/raspberry-pi-zero/products/zero-adaptor-kit
What adapter are you using, and are you sure its plugged into the Data Port, and not the Power only one? I ask because the Pi Zero will back power from the Data Port. You could get them backwards and the Pi will boot up. Your USB peripherals won’t work though.


#3

Hello alphanum, thank you for your time.

To me data USB is the one between the HDMI output and the power USB input.

USB Power input
I use a straight cable : no adapter to power side
The power I use is the same I use with my Raspi3 : 5V 2.5A

USB Data input
I use the same adapter as you : https://shop.pimoroni.com/collections/raspberry-pi-zero/products/zero-adaptor-kit the hub is an interesting tool I will think about in a near futur.

Is there a way to switch USB power input and USB Data input ?
(or at least to check the current configuration of the USB port)


#4

Yes, the DATA USB is the one between the HDMI and the other USB port. You can’t switch them, they are hard wired as is. A K400 is one of the keyboards I like to use with mine, as it has the trackpad built in. I often want to plug more than one USB device in so I use the hub quit often. I have one of each from Pimoroni, one with the mini USB and the one with the normal full sized USB plug. I have a couple of Pi A+ 's here where a hub comes in handy. Like the Pi Zero, they only have the one DATA USB port.
Are you running Raspbian on the Zero? Just to rule out a corrupted install I would redo my SD card with a fresh image. If the USB still doesn’t work after that, its either the Pi Zero is bad, or your USB adapter is bad.


#5

Yep,
I have 2 adapters, so I can’t imagine that both are bad!

And yes I’m running Raspbian on the Zero.

You’re right I will redo a brand new fresh install of Raspbian and see what happens.
Thanks


#6

This is it : I have now a fresh install of Raspbian stretch.
And the result is the same : I can’t use my usb k400 keybord.


#7

After an update / upgrade and reboot…
The problem is still here : I can’t use the Data Input USB

$ lsusb :
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I really don’t know what to do.


#8

It sounds to me like that Pi Zero is defective. I’d try getting a refund or replacement.


#9

Ok, thank you alphanum for your time.

I’m trying to get in touch with support (for a week now)


#10

"Contact us’ link on the main page? https://shop.pimoroni.com/pages/contact-us
I’ve had nothing but top notch prompt replies the few times I’ve had to use it. And link to this thread in your relies to them.
@gadgetoid should be able to help you out.


#11

Ho you’re right, last week I directly mailed the support.
Probably not the right method! Any way I’ve just tryed the form you linked me.
Thank you very much


#12

The Support told me to send back the Pi Zero.
The thing is : i’m abroad so it’s a bit less simple :)

By the way I’ve ordered an other Pi Zero from adafruit website;
… And an other USB adapter.

Huhu : using the https://shop.pimoroni.com/collections/raspberry-pi-zero/products/zero-adaptor-kit adaptater with my the adafruit Pi Zero do not work either.
But with the new USB adapter : the keyboard works with my (new) adafruit’s Pi Zero W and my (old) pimoroni Pi Zero W.

So here is the point : I can’t use my keybord with the pimoroni USB adapter.

Now one last thing : I have to test the pimoroni adapter to be sure that it do not work at all or… Just for this K400.


#13

Ok, from the sounds of it, it was that USB adapter that was bad all along. Test it if you want, my bet is nothing works with that adapter. Duds happen, not very often but it happens.