Is my Hyperpixel 4 touch faulty

I purchased a Hyperpixel 4 touch (the rectangle one) and the image quality is really bad, looks like it’s displaying a really low resolution and there are strange artifacts when the screen is starting up and shutting down.

I’ve tried installing fresh install of both buster and bullseye (the newest one with drivers built-in) on both an RPi 4 and RPi 3B+ following your install instructions and it’s always the same.

I have a number of the square hyperpixel screens (both touch and non-touch) and the picture quality is excellent, so I’m sure I’m doing something wrong but do just want to confirm there isn’t an issue with the screen before I go mad trying to fix it with software tweaks.


what OS are you using , did you see this in the product listing .
" Hyperpixel 4.0 Square, is not yet fully compatible with Raspberry Pi OS Bullseye**

I’m using Raspberry Pi OS, I tried both Buster and the very latest Bullseye build which contains the required drivers built in. I’ve followed any installation instructions provided by Pimoroni to the letter.

Doesn’t look happy! What PSU are you using?

The official Raspberry Pi ones, either micro-USB or USB-C, depending on whether I’m testing with a RPi 3B or RPi 4.