Micro:bit


#1

My MicroBit fails to pair with other Bluetooth devices. When I enter the Bluetooth pairing mode it displays PAIRING MODE! then displays some kind of symbol. It had previously been paired with my iPhone 5C but I deleted this pairing.

I’m not certain but I think this error occurred after I had create a microPython script to use the microbic to control a Raspberry Pi robot (see http://www.watkissonline.co.uk/wordpress/?p=7907) which was successful.

I have downloaded the latest firmware (which I already had) and copied it to the Microbit in MAINTENANCE mode but this did not help. I have also emailed the BBC Microbit support but haven’t heard back. I would be grateful for any ideas.


#2

MicroPython does not support bluetooth on the micro:bit, so yes, you would need to reflash a runtime that provides that functionality.

I know I toyed around with bluetooth after reflashing the simple example the Microsoft Code Block editor provides and that worked for me. Not sure if that can help you but you could see if going down that route leads anywhere.


#3

Thanks for your prompt reply. I’ve tried flashing the example in the Microsoft Code Block Editor and the example using Microsoft Touch Develop editor. They both run but still the same failure when I enter pairing mode.


#4

strange. Can’t say I toyed around much with BT and the micro:bit. I will try to see if I have difficulty pairing with an iphone rather than an iPad.

btw, to pair I used the following app:

… not sure there is a way to bypass it but I thought I should mention what my process had been in case that’s where the culprit lies.


#5

Thanks, that worked. I think I mistook the PAIRING MODE! as an error message. Sorry for the confusion. Grateful for your help.