Pi4 Bluetooth connection problems

Esentially this is a copy of post i have made on raspberrypi.org

Hi, i’m a complete neub to all raspberry. I received my first devices.

The OS is rasbarry Pi OS desktop . the issues occurred regardless of whether it was recommended or full. I haven’t tried light and I haven’t yet tried other distros.
OS installed with pi imager.

For hours now i have been trying to connect to Bluetooth devices (speakers, legacy keyboard)
I have tried from the gui and also cli.
I have: edited


ExecStart=/usr/lib/bluetooth/bluetoothd -C
ExecStartPost=/usr/bin/sdptool add SP

I have tried using both bluetoothctl and rfcomm

I have ensured the device is trusted and tried agent NoInputNoOutput although the latter just returns “agent is already registered”

Regardless of the method upon pairing the device will connect then seconds later disconnect.

Later attempts to connect return an error

Connection via gui shows messages not visible in cli. Specifically :

  1. pairing request sent to device.
    -in bluetoothctl it shows connected then seconds later disconection
  • then -curiously - several seconds later
  1. pairing failed- time out was reached.
    i say curiously because i would have expected the error at the same time of the time out.
    Did the module receive a reply but one that wasn’t ?

When trying to conenct to the keyboard another step existed which was the pin request.
I enter the pin and then it carrys on to -pairing failed timeout.

After the process, they remain paired but I am unable to connect . another message I receive from GUI is
"Connection failed no usable service on this device. "

I have tried with wifi on 5ghz and with no wifi in place.

I have also tried the devices in pi W then used the sd from the piW in the pi4.

With the piW it’s a breeze and devices connect straight away.

The issue exists regardless of the cable (one of which is Anker) used or the charger

More strange behaviour after rebooting with a new cable… but that was solved with a further reboot…
I just tried to remove one item through GUI and it failed.
GDBUs…error.org.bvluez.Error.NotReady: Resource not ready
Also failed through blutooth returns a similar error.info

Any help would be appreciated. Could it be a faulty BT chip?