Pi 3 no sound or bluetooth


#1

I have just bought two Raspberry Pi 3 models and on powering them up for the first time there is no sound and the Bluetooth does not detect my keyboard. I have been through all the settings on raspian. Help!!!


#2

How are you trying to get sounds out of your pi? Are you trying to get sound through the HDMI cable to a connected TV / monitor or have you connected some headphones or speakers to the 3.5mm port?

It can help to force the Pi to send audio directly to the device you are trying to use instead of relying on the auto detect function. To do this open up the terminal window and type…

sudo raspi-config

Then go to the “Advanced options” then “Audio”. From here you can either select the Auto detect option if you wish, or if this doesn’t seem to work then try forcing the audio down either the HDMI or the 3.5mm jack - depending on what you have connected.

After this it’s a good idea to reboot the Pi. When it’s back up and running try the sounds by opening a terminal again and typing

sound-test

If that doesn’t work there are still other things to try ;-)

As for your bluetooth problems, you haven’t said how up to date your version of Raspbian is. Have you tried making sure the software is installed …

sudo apt-get update
sudo apt-get install pi-bluetooth


#3

as @thermalhound said, a fairly fresh Jessie is necessary for the on-board Bluetooth adapter to work.

pi-bluetooth should be already installed otherwise it’s likely you will be missing the necessary device tree overlay, so make sure to also:

sudo apt-get upgrade

then, there is the sticky point of the version of blueman included in Jessie, which is fairly buggy… in fact pairing to HID devices is documented as broken in that version, so try to pair from the command line.


#4

The sound now works, Bluetooth is installed but there is no information on how to use it.
Thanks
Alyn


#5

there is a bluetooth graphical frontend available called blueman that may simplify setting up devices and services. It is extremely buggy in the version included currently in the raspbian (jessie) repo however.

for this reason I have been experimenting with a script that will allow you to install a newer version without too much fuss, and my experience with this new version, namely 2.0.3, has been a vast improvement.

so you could try the following, as an alternative to using the command line:

curl -sS get.pimoroni.com/bluetooth | bash

… When asked if you want to install the latest version of blueman say yes (this will only be an option on a Pi2 and Pi3 incidentally).

if you are told you need to restart blueman then the easiest is probably to reboot.

Anyhow, once that is done you will find blueman as ‘Bluetooth Manager’ under Preferences. Use the ‘search’ function to scan for nearby BT devices, then pair them (and trust most likely, so they may connect automatically after reboot).

One particular reason to use this specific version, other than I have found 1.9.9-alpha particularly temperamental in various areas, is that you can easily enable OBEX transfer to the Pi using the ‘Local Services’ function of blueman.

… obviously it’s possible to set up OBEX transfer outside of blueman, but if you don’t feel like learning how to do it from the cli (and I sure didn’t) then this version at least as a functional interface for it!


#6

Some additional information, Bluetooth is installed and running but gives the error “SAP driver initialisation failed” and “SAP server operation not permitted”


#7

that’s likely nothing to worry about. are you able to pair your keyboard now, if not, post a detailed account of messages or failures you run into, with screenshots if at all possible.


#8

Bluetooth is partially working. If I scan for devices it finds none, but if I use a mobile phone to scan Bluetooth it can find the Pi. I have also tried the command line but again it cant find any Bluetooth devices.


#9

are your devices discoverable? I know I had to enable it on my chromebook before the Pi could see it (and, as you with your phone, the ChromeBook could see the Pi).

of course a keyboard should be auto-detected, have you paired it with something before? maybe that device is claiming it right off the bat?


#10

Bluetooth on the Pi is still rubbish. I can detect a new Bluetooth keyboard, pair it, then 10 seconds later it disconnects. It is unuseable.


#11

did you also trust it? not sure if that will solve the problem but without it you’d have to manually reconnect in case of disconnection, which may or may not be part of the problem.


#12

No, the problem is nothing to do with trust. If I pair the keyboard to a Windows PC it asks for a 6 digit code to complete the pairing. On the Pi it does not ask for this code so that’s why it disconnects. The Bluetooth implementation on the Pi is rubbish, it is unuseable with standard Bluetooth devices.


#13

right, are you using the command line, or blueman?

when pairing from the command line you have to declare the agent capability, like so:

# bluetoothctl [NEW] Controller 00:10:20:30:40:50 pi [default] [bluetooth]# agent KeyboardOnly Agent registered [bluetooth]# default-agent Default agent request successful [bluetooth]# scan on

You should then be able to initiate the pairing which will include a pairing request with code.

… I can’t say I had the most fantastic start with bluetooth on the Pi either, and ran into a myriad of troubles. I read and re-read the Arch wiki until I was Bluez in the face, and got most of what I needed out of it, eventually.

That said, I honestly strongly recommend installing Blueman 2.0.3, it’s not perfect but will simplify a lot of tasks that should really be simpler but aren’t :(

This is in fact why I went to great length assembling a script that pulls the debian Jessie backport, as I can’t be bothered to figure out how to pair a mouse or keyboard using the cli when I need it done. Same for OBEX 2-way exchange.


#14

I am trying to use blueman but I don’t get any option to enter a code. I cant use the command line as I have no working keyboard. Whatever I try nothing seems to work.


#15

Blueman 1.9.9-alpha, as available from Raspbian repo, is broken for HID devices pairing, 2.0.3 should work. See script mentioned above to install it.

Failing that then your best bet, if you don’t have a USB or IR keyboard to hook up to the Pi temporarily, is to ssh into the box and try pairing from cli.


#16

I used your script to install blueman so it should be the same version. I am currently working on my Pi2 so I cant check the version right now


#17

You may also want to do the following:

sudo apt-get -f install
sudo apt-get install notification-daemon

if the first wants to remove blueman then that would mean you ran the script before I fixed all the dependencies. The notification-daemon is what makes it possible to see what code is required to finalize the pairing (without yet another arcane ritual) and is also something I added some time last week.