MLX90640 read/write frame error

Hi everybody,cd cd

I am new to Raspdskjadsdberry Pi and Linux and Pimoroni. So I bought a MLX90640 for a small project and tried get it run on my Raspi B 3. After following the instruction on Github, I ran the fbuf but got error
I2C read frame error!
I2C read frame error!
I2C read frame error!
I2C read frame error!
The framebuffer device was opened successfully.
Original 1024x786, 32bpp
I2C read frame error!
Failed to get frame data.

One thing is that I couldn’t change the baud rate in the /boot/config.txt. My config.txt does not have such line. The I2C communication is enabled in the Raspi.

Any suggestion? I want to get the Raspi to successfully read the video from the mlx90640 and then use OpenCV for some simple image processing.

Your help is appreciated.

You can add a / that line to the config.txt file. I do it all the time.
Also be aware that any line with a # at the start of it is ignored.
You have to remove it if its there as part of your edit.

yes I now added the dtparam=i2c1_baudrate=400000 in the config.txt but still got the same error: I2C read error.

Any suggestion is appreciated.

Double check your soldering, upload a picture of that if you can. And double check your wiring.
My Linux skills are basic, and I have no C+ training. I don’t have any other ideas?