Need help w/ Inky Impression 7.3

I’m new to Python and RPI. I have a Raspberry Pi 3 and an Inky Impression 7.3. I’ve connected them with the 40 pin header and managed to download the Inky software to my RPI by creating a virtual folder wit Venv. However, when I try in terminal to run “from import auto”, I get the following error: “bash: from: command not found”. I’m not sure if the Impression is even powered on. Is there an LED or someway for me to know?

I assume you’re following these instructions: GitHub - pimoroni/inky: Combined library for V2/V3 Inky pHAT and Inky wHAT.

The code you tried needs to be run at the Python prompt, so you need to run the python3 command to get a Python prompt first.

Thank you for the quick reply. Yes, those are the instructions I’m trying to follow. I didn’t realize this about running from python and that seems to have gotten me a step closer, but now I get this error:

from import auto
Traceback (most recent call last):
File “”, line 1, in
File “/home/folder/InkyTest/lib/python3.11/site-packages/inky/”, line 5, in
from .phat import InkyPHAT, InkyPHAT_SSD1608 # noqa: F401
File “/home/folder/InkyTest/lib/python3.11/site-packages/inky/”, line 12, in
from . import inky, inky_ssd1608
File “/home/folder/InkyTest/lib/python3.11/site-packages/inky/”, line 4, in
from PIL import Image
ModuleNotFoundError: No module named ‘PIL’
display = auto()

after some searching, from the command line, I’ve input:

pip3 install pillow

That seems to have taken care of the error, but now when I run python and type:

from import auto
display = auto()

I get:

display = auto()
Traceback (most recent call last):
File “”, line 1, in
File “/home/gregorpb/InkyTest/lib/python3.11/site-packages/inky/”, line 83, in auto
raise RuntimeError(“No EEPROM detected! You must manually initialise your Inky board.”)
RuntimeError: No EEPROM detected! You must manually initialise your Inky board.

So, following the instructions, I see there’s no EEPROM on my display, so I type:

from inky import InkyPHAT

and it returns a >>> prompt. I follow with

display = InkyPHAT(‘red’)

and get another >>> prompt. Then,

display.set_image(image) returns the follwing:

Traceback (most recent call last):
File “”, line 1, in
NameError: name ‘image’ is not defined

There are examples for the color Impressions line in the repo: e.g inky/examples/7color/ Have you tried to run any of them?

I tried to run and got this:

#!/usr/bin/env python3
import time

from import auto

inky = auto(ask_user=True, verbose=True)
Failed to detect an Inky board. Trying --type/–colour arguments instead…

usage: [-h] [–simulate] --type
[–colour {red,black,yellow}]
: error: the following arguments are required: --type/-t

That message is telling you to use the --type “inkyboard” to specify which Inky board you have.

“impressions73”, “7colour” or “impressions” seem like the right ones to try. e.g. in the examples/7colour directory, use the command:

./ --type impressions73
./ --type 7colour
./ --type impressions

See if any work.

If you don’t know Python, learning it is really useful on the Pi!

1 Like

Thank you so much. This is great. I ran it as you suggested an got the Impression to cycle through colors. I am starting to learn Python, but it’s a steep learning curve.

Quick question - when I run specifying the board, while it does cycle through the colors, I get this message in terminal:

Failed to detect an Inky board. Trying --type/–colour arguments instead…

Color: Black

1 Like

I’m guessing the auto call tries to identify the board first, fails and prints the message that it’s looking for a --type option as a fallback.

Keep trying stuff and read the code to understand what it’s doing - the library code too.

The online Python documentation is good, and you can download a copy for quicker access - the latest release of Raspberry Pi OS has Python version 3.11.2.

1 Like