Can't get Inky Impression to work

Hi there,

I’m having a lot of trouble trying to get an Inky Impression working on a Raspberry PI using the latest Bullseye release. I’ve installed the software using

curl | bash

This fails to download some font packages but is otherwise successful.

I then tried running the examples under Pimoroni/inky/examples/7color.

None of the ones that actually use the screen work. They all return this:

Traceback (most recent call last): File "/home/pi/Pimoroni/inky/examples/7color/./", line 7, in <module> inky = Inky() File "/usr/local/lib/python3.9/dist-packages/inky/", line 144, in __init__ eeprom_resolution = _RESOLUTION.keys[self.eeprom.display_variant - 14] TypeError: 'builtin_function_or_method' object is not subscriptable

Even stranger, copying the examples outside of that directory has them fail with ModuleNotFoundError: No module named 'inky.inky_uc8159'; 'inky' is not a package.

I do want to note that i2cdetect does see the device, and the example using the buttons does work, too.

Is this library (and installation script) perhaps not updated for the latest Bullseye? That’s all I can think of…

There is a Raspberry Pi OS (Legacy) option in the Pi Imager that will get you Buster instead of Bullseye. It’s under Raspberry Pi OS (other)
Might be worth a shot to get your Inky working.

It’s definitely worth a try, but I was saving that in case I didn’t find any other solutions.

I have now tried Buster also, and get the exact same results ):

That sucks, not sure what to try now?

Looks like there might be a bug in the most recent version of the library - there’s a Github issue to track it here: Inky Impression - EEPROM Error · Issue #136 · pimoroni/inky · GitHub

Thanks if you were the one who opened it!

It looks like that issue is closed by the person who opened it (who was not me) despite there being no solution other than a workaround which also requires increasing the screen’s timeout to 60 seconds…