Inky Impression challenges

I have a new inky impression 5.7" screen, and I can’t seem to get it to work (reliably).

Used a clean install on a new Pi3 A+ . Updated everything, connected without ribbon cable directly to Pi. Enabled SPI, I2C (and confirmed multiple times). Installed per instructions (honestly, have tried both GitHub manual install and the curl |bash) and tried the Pimoroni examples. nothing worked. it auto detects ‘Found: 7-Colour (UC8159)’ and the python scripts end, without anything changing on the screen. Last thing I ran was

I then installed SlowMovie libraries and fiddled with that. the weird thing - is when I ran the which takes a random frame from the included mpeg movie - the screen flashed and changed to what I expected the output to be from Pimoroni I tried it again, and it didn’t work. So then I ran from the Pimoroni folder and nothing happened. Then I ran the SlowMovie hello again and the screen flashed. Ran it again - voila! Then it displayed a frame from Psycho.
Then nothing ever worked again. I looked at the demo python code for SlowMovie and it actually was outputting to a wave share device. (see here: SlowMovie/ at main · TomWhitwell/SlowMovie · GitHub) I changed the preference to the Omni EPD library with the appropriate inky.impression (which I had installed) and again… nothing would work. The Omni EPD test wouldn’t work either.

I decided to start from zero - so I made an entirely clean new install of Full Raspbian, updated it, installed ONLY the Pimoroni Inky libraries (latest one again) and again, it finds the screen, but won’t display anything on it. I’m stuck on the image from Psycho.

So then I swapped to a new 3 A+ device…same thing. So then I tried a 4 B+ from my gaming rig - with a new clean install…same thing.

Then I ran and on all 3 - I get the following. Should Color be none?

Found: 7-Colour (UC8159)
Display: 600x448
Color: None
PCB Variant: 1.2
Display Variant: 14
Time: b’2021-12-17 13:00:28.0’

Anyway, any help or suggestions would be great. I’m completely lost - and have no idea that the only time it worked (which I can’t repeat) is when I ran that hello that was importing “from waveshare_epd import epd7in5_V2 as epd_driver”
which should just be -wrong-.

any advice would be great!

cheers, Chris

I installed the omni drivers - and now I can draw on my color screen in BW using the wave share epd.epd5in83 controls. so THAT works - but the inky.impression driver does nothing.

for those curious -

pi@raspberrypi : ~ $ omni-epd-test -e waveshare_epd.epd5in83

works on my inky Impression.

pi@raspberrypi : ~ $ omni-epd-test -e inky.impression

does nothing. any thoughts?