Inky Impression 5.7" detected, never updates

Ever find one of those problems that some people see, then nobody ever answers? There’s an xkcd for it: xkcd: Wisdom of the Ancients

I have an Inky Impression, it’s detected:
Found: 7-Colour (UC8159)
Display: 600x447
Color: None
PCB Variant: 1.2
Display Variant: 14
Time: b’2022-03-07 09:40:09.3’

But the demos don’t work…e.g. shows the following:
Detected 7-Colour (UC8159)
Cleaning cycle 1

  • updating with multi
    /usr/local/lib/python3.9/dist-packages/inky/ UserWarning: Busy Wait: Held high. Waiting for 0.20s
    warnings.warn(“Busy Wait: Held high. Waiting for {:0.2f}s”.format(timeout))
    /usr/local/lib/python3.9/dist-packages/inky/ UserWarning: Busy Wait: Held high. Waiting for 32.00s
    warnings.warn(“Busy Wait: Held high. Waiting for {:0.2f}s”.format(timeout))
  • updating with black
  • updating with white

Only, nothing ever changes…

Are you on the most recent version of the Inky software, released last week? It includes fixes for some persistent busy wait issues: GitHub - pimoroni/inky: Combined library for V2/V3 Inky pHAT and Inky wHAT.

(and possibly relevant issue here: The driver doesn't work anymore · Issue #132 · pimoroni/inky · GitHub )

I’m watching closer and what I originally thought was a ‘safe dependency fallback’ may not:

E: Unable to locate package python3-geocoder
Apt failed to install python3-geocoder!
Falling back on pypi…

I was really hoping to get the examples running before delving into coding (as it’s been awhile), but it looks like I may have to dig in and write something.

Those apt failed messages in the installer are expected - it means it’s checking the apt package manager for the dependency first, and if it’s not available on apt it will get it via pip instead.

Do you have the inky header pushed down as far as it will go on your Pi’s pins? If the connection is not solid it can sometimes make enough of a connection for I2C to work but not enough for SPI connection. Also could be worth checking you’ve got I2C and SPI enabled in sudo raspi-config!

I2C and SPI are enabled, I’ve reflowed the pins…still not having any joy. :/

I’d assume that since it has the ‘girl doomscrolling’ image, that it worked right for someone, somewhere, at some time.

Hmm - what combo of Pi/Raspberry Pi OS version are you using?

Do all the examples fail in the same way - have you tried the ones that are specifically for Inky Impression in the 7color folder?

I’m using a RPi Zero W (and swapped in another, just to be sure) and Raspberry PI OS LITE from the Imager v1.7.2…which makes me think maybe I need to use the full OS as lite images tend to be not quite as thoroughly QA’d

Just rebuilt the install using a full 'Raspberry pi from Debian Bullseye released 2022-04-04…still no joy. :/

Boo :( No luck with the 7color examples?

Can you post a photo showing the soldering on your Pi’s header?

Not great, but not awful, either: Imgur: The magic of the Internet

Looks like everything’s making sufficient contact there - you could try unplugging and replugging the ribbon cable on the back of the Inky in case it’s become dislodged during transit?

If not, possible that you might have faulty hardware :( If you drop an email to (with a link to this thread so they don’t ask you all the same questions again!) they’ll be able to get it sorted.

Just checking back in. Seems like the original E-Ink display was the issue (and not the controller HAT) The replacement is working as expected! (and does so on the old HAT as well, the old e-ink display doesn’t work in either setup.)

1 Like

Glad to hear you’re up and going - and interesting that it was a faulty display causing the problems! I’ve passed that info on.