Neopixel stick not working in Pan Tilt Hat


#1

Just received two Pan Tilt Hats from Adafruit last weekend. The servo control works well with the example python scripts, except the adafruit neopixel strip is not working as in the neopixels.py or grbw.py. Tried both Pan Tilt hats with same results. This neopixel strip is checked with Arduino and works fine. I tried both Pi2 B+ / Wheezy and Pi3/Jessy fresh install. Same issues for all the possible combinations (hardware/software). I could not figure out why. Anyone experience the same issue with neopixel strip/PanTilt hat combination?


#2

It’s possible (although unlikely 'cos I have a fancy test script that’s supposed to prevent it) that I broke something in the latest release of the library.

How are you hooking the NeoPixel strip up to PanTilt HAT?

You could try regressing the library:

pip uninstall pantilthat
pip install pantilthat=0.0.3

#3

The neopixel connection is shown in the pictures attached. Red +5V/White Din/ Black GND. That works with Arduino.
I could not uninstall pantilthat with following error message “Not uninstalling pantilthat at /usr/lib/python2.7/dist-packages, owned by OS”.
Pimoroni dashboard did not have uninstall function either.
Please refer attached pictures:


#4

Gah, sorry those commands should have been:

sudo pip uninstall pantilthat
sudo pip install pantilthat=0.0.3

Simon says!


#5

I already tried “sudo pip uninstall pantilthat” with the same error message.
FYI. I installed the pantilthat using Pimoroni Dash Board. Did it anything to do with this uninstalling issue?


#6

the current version available via dashboard/apt-get is version 0.0.3 as the next version as yet to propagate there. In other words, your issue exist in that older version.

If you’d like, you may roll onto the next one by running:

sudo apt-get remove python-pantilthat python3-pantilthat
sudo pip install pantilthat && sudo pip3 install pantilthat

That said, without knowing exactly which neopixels you are using if is a hard one to assess, do you have a part number of a shop link that we could check out?


#7

That is a good news. I will try the new command line, or update as the Pimoroni dash board gets update.
My neopixel stick is from Adafruit: https://www.adafruit.com/product/1426
Thanks.


#8

I tried the commands that was completed without error, but made no difference.
I also tried another neopixel stick (photo) which is essentially the same one and also same result. I am not sure if the NeoPixel “C” in the label means anything related to this issue.


#9

Pretty sure these are run of the mill RGB NeoPixels, and should be the same ones I tested the firmware with. Colour me confounded! No doubt we’ll have some lying around to test and try to re-create. Unfortunately I’m presently away from the workshop and don’t have any to hand right now!


#10

we’re out of stock right now on that particular model, but we’ll test closely related ones and see if we can figure it out. Thanks for your patience!


#11

Sounds good.

Thanks for following up in advance.