No Module error

A noob here, both to Pi and HATs. I soldered a GPIO Header and connected the Enviro+ and did stuff according to here. But when I run any example I get the error “Module xxxx not found”. What could be the issue? Does Enviro+ has lights or anything to show it is getting power? Also, as I said, I am a novice and I am not 100% confident my soldering is good, so I attached an image.
Any help is appreciated.
Thanks in advance

Which module, specifically?

Normally they’re just a “pip install” or “apt install” away, but our installer should be handling all that for you.

Thank you.
All the modules give the error. I installed according to the tutorial using

git clone
cd enviroplus-python
sudo ./

Then executed all the examples. All of them give “module [specific to each example] not found”

Specifically, if I run
I get

Traceback (most recent call last):
File “”, Line 4, in “module”
from bme280 import BME280
ImportError: No module named bme280

(Replace “module” with <module&> (here no & also))

You’re not the first person to have this problem. I have a feeling I’ve broken something.

I am sorry but what do you mean?

Just pushed an attempted fix. In your enviroplus-python github folder run:

git pull origin master
sudo ./

And see if that fixes the missing requirements.

Edit: Otherwise you should be able to fix with:

sudo pip install pimoroni-bme280 pms5003 ltr559 st7735 ads1015

Thanks. It seems I am getting another issue I resolved earlier where I get error “can not resolve
I’ll reply back as soon as I fix this access issue and execute commands you mentioned.