No Output UnicornHat HD


#1

As the title suggested I can’t display any output on my Unicorn Hat.

So far I’ve followed the following steps:

  1. Updated my Pi by running the following:
    sudo apt-get update
    sudo apt-get upgrade
    sudo reboot

and 2) Installed the HAT software:
curl https://get.pimoroni.com/unicornhat | bash

  1. Then attempted to run the examples provided
    cd ~/Pimoroni/unicornhat/examples/
    sudo python ./EXAMPLE NAME.py

I didn’t get any errors during installation, nor while running the examples, but no output is visable on the HAT. I’ve tried both a Pi3, and Pi0W, both with the official power supply, using the latest Raspbian Stretch.

Any ideas on what i should try next?


#2

Unicorn HAT HD needs the Unicorn HAT HD library: https://github.com/pimoroni/unicorn-hat-hd

Or: curl https://get.pimoroni.com/unicornhathd | bash


#3

Let me flash a new SD card, and give this a try


#4

EDIT: Ignore this thread, I have just realized I have incorrectly received a regular UnicornHAT, instead of the UnicornHAT HD I had ordered. Thanks for helping

Installed on a fresh SD card, but now the HAT just displays “noise” (random LED’s on), and isnt affected/doesn’t change when I run the scripts

Like this:


#5

This may be because audio is still running- which conflicts with the functionality of Unicorn HAT (both analogue audio and Unicorn HAT try to use the onboard PWM hardware to produce their signals). Make sure: dtparam=audio=on is commented out in /boot/config.txt, ie: any occurrence of this line should have a # before it.