Official 7" Raspberry Pi Touch Screen FAQ


#21

Hi,perhaps someone here can help me. I followed this webpage’s instructions. Made sure I downloaded the Raspbian image from the official Raspberry Pi site. When I boot up my display, it works wonderfully for about 5-10 minutes, then out of nowhere it suddenly starts not responding. Sometimes it gets stuck right before it stops responding and continously thinks that it is being touched in a single spot. Even when I attempt moving the cursor with a mouse, the cursor jumps back to that spot on the screen where it thinks its being touched.

I’ve quintuple checked my connectors.
I’m using the 5V and GND GPIO pins to power the pi and board together, from the pi.
I did the
sudo apt-get update
sudo apt-get install --reinstall libraspberrypi0 libraspberrypi-{bin,dev,doc} raspberrypi-bootloader
sudo reboot
I am using the Raspberry Pi 2.

The only thing from this guide I have not done is purchase the official raspberry pi power supply, as I am waiting for it to ship this very moment. I’m currently using a 5 Volt 1 Amp power supply, but I’ve never gotten the “little rainbow square indicating undervoltage in the top right hand corner of the LCD.” on my screen. Could that still be the problem though? It seems unlikely given that it functions perfectly fine for 5-10 minutes before acting up, as well as the fact that it never states that its in undervoltage mode.

Basically, could someone tell me what the most likely problem I’m having is so I can continue debugging it? or should I try to send it back if the new raspberry pi power supply doesn’t work?


#22

I’d definitely be suspicious of the capacity of a 1A PSU to guarantee stable operations…

What you can do if you have a micro USB cable lying around that you can hook up to a computer is power up the display from that host instead of the GPIO, as I believe 500 mA is enough for it to work.

… if nothing else, it will tell you if your 2A PSU arriving in the post is what you need to get off that persistent spot!

Edit: just tried here and the display works fine, as expected, when powered up from my Mac.


#23

The touchsceen features do now work with Ubuntu MATE 15.10 due to the upgrade in the kernel that it uses.

Touchscreen does not work out-of-box with version 15.04… at least from my experience. :)


#24

I have a strange Problem with the Screen.
It works perfect, besides that one eigths or so at the bottom/top (if rotated) are not responding to touching. With the mouse i can move the cursor everywhere but not with my fingers. Thats very annoying because I only use the rasp with the touchscreen nothing else. Has someone any idea to fix it. (I’ve reinstalled the system (NOOBS) but even in the installer this problem is apparent)
I’m using Pi2


#25

@gadgetoid , could you please provide more details on how to fit the pibow coupe to the back of the raspberry pi? Do you use all layers? Do you need different screws?


#26

It’s deceptively simple; bolt the very bottom layer of the PiBow coupe directly onto the metal mounting posts above the display driver board, and then build the rest of the PiBow coupe on top of that.

You shouldn’t need any additional screws, the bottom layer of the PiBow is held on with the very same screws that the Pi would otherwise be secured with.


#27

Wow that worked out very fine. Wouldn’t have figured that out myself. I like your solution! :)


#28

Greetings All,

I’m sorry to be the dope who just can’t seem to figure this out. But, I’m still not able to get my screen to rotate. I’ve tried the config.txt solution presented above as well as the sudo tee solution also presented above. Still nothing. Is there a screen rotate for dummies somewhere?

Ryan


#29

are you on Wheezy? if so, some users have reported that the line needs to be right at the beginning of the /boot/config.txt file if I recall correctly.


#30

Hello, new here, and to the Pi. I built a car media center out of the Pi2 with Touchscreen and was wondering if there was an option to enable single tap? I’d like to not have to fumble around trying to get the double tap to switch songs while driving.


#31

Very cool display!

I’m wondering if you can post some details on what you used to create it?


#32

Really enjoying our new screen which was a xmas present! Working well except I’m not clear if it has sound / speaker - and if so, how you activate the speakers. If it doesn’t, is there a way to use headphones with it?

Paul


#33

Hi Paul! The official touchscreen display does not have speakers. You’d need to connect something up to your Raspberry Pis audio output!


#34

Thank you! That makes sense now

Paul


#35

It just worked for 1 hour with the regular instructions. Now HDMI has taken over because the display isn’t responding. Is there a way in the config.txt to force the use of the DSI Display?
The power supply (5V 2A) for the display and the DSI connections are ok. I’m using the Raspberry PI2 with the Hifiberry Amp+ and also a separate power supply of 18V

Best regards
Ronald


#36

as far as I know the DSI is always taking precedence if present.

Have you tried powering up the display with its own PSU?

… I’d probably recommend you start a new thread and post pictures or full detailed overview of what is connected to what.


#37

Thanks, I don’t think it is a hardware problem. Perhaps someone sees something strange in my config.txt:

disable_overscan=1

dtparam=audio=on

hdmi_force_hotplug=1

config_hdmi_boost=4

dtparam=spi=on

dtparam=i2c_arm=on

gpu_mem=128

lcd_rotate=2


#38

I’ve just tried this exact set of parameters in /boot/config.txt on a clean Jessie Lite image, with both HDMI and touchscreen attached, it works.

The obvious would be that the DSI cable was not secured properly and came loose.


#39

Thanks RogueM, this information helps me a lot. So the focus is not the boot.txt. I’ve tried:

  1. disconnect the Hifiberry Amp+, the behavior with both HDMI and touchscreen attached works. The touchscreen is working.

  2. connecting the Amp+, both HDMI and touchscreen attached, the touchscreen works.

  3. connecting the Amp+, only HDMI attached, the HDMI works.

  4. Turn everything off, AFTER situation 3, now both HDMI and touchscreen attached, only HDMI works.

My first conclusion: the Amp+ ‘feeds’ a kind of memory bit inside the Raspberry Pi, telling it to feed only HDMI. Disconnecting all the power has no result. Only disconnecting the Amp+ from the Raspberry Pi, gives a clean status like situation 2.


#40

I can only restate that I do believe your problem is power related. When you first start your Pi, the power draw will spike and I would suspect that some protection circuitry shuts down the touchscreen just long enough for the system not to detect it when it boots.

… that said I could very well be wrong, but I doubt there is any software cause to what you see.