7" touchscreen rpi 2


#1

hi

having received my shiny new screen yesterday, i have connected it all up and ensured that all the connectors are fully seated, also flashed the latest rasbian (jessy) onto the sd card, booted on an external screen and updated, upgraded and rpi-update… just to ensure that its all up to date…

my new shiny screen is not working… check all connectors, look fine seated as far in as they go and are straight, dsi connector is in as per instructions. pi is powered form the screen board on the gpio header as per instructions…

any more ideas?

thanks
Simon


#2

You write “…booted on an external screen…”.
Is the external screen still connected?
If so, disconnect it, and then it should work.


#3

Have indeed tried that to no avail unfortunately


#4

Could you post a photo of your setup. Also is the text on the cable between the Pi and the display driver board showing on the inside, or the outside of the loop?

Don’t ask me why this matters, but it seems to so it’s worth a punt!


#5

Pictures as requested. I have tried reversing the dsi cable to no and had no luck. The system is being powered from a 2a supply into the display board and linked up to the pi (which as powers and appears to be booting)

Thanks


#6

Any way you cab double check the PI is actually booting? I’ve seen a few instances of cards becoming corrupted after updating, and had a dodgy one myself. Worth a check!

Did you try the DSI cable with the text on the inside of the loop? I think the blue end then goes in the driver board with the contacts facing upwards. This seems like voodoo because the cable should function the same either way, but it’s apparently fixed a few problems… it probably is voodoo!

Can you SSH or otherwise into the Pi to try some diagnostic steps to see if the display is being detected at all?

Also can you see a faint picture. I’ve seen a couple of instances of the backlight not firing up, which until close inspection also looks like a totally dead display.

Sorry to drag you through a list of debugging steps, but it’s all I can do at the moment!


#7

That’s quite all-right… Was hoping someone would be able to do that.

I can SSH to the pi, and if I disconnect the dsi cable and plug in a hdmi display it works (needs a reboot).

I have tried the dsi cable in both ways around always with pins facing away from the LCD on the driver.

And as far as I can tell I have no image at all on the display.

I have set the pi to boot straight into the desktop and not stay in command line just in case it needed xserver running, still no luck.