Raspi 7" Touchscreen Problem


#1

Finally got time to build it and I’m getting nothing from the display.
Followed assembly instructions:

Followed the FAQ here on the forum with no luck.

Using raspian-stretch (2017-11-29) on a Raspi 3
powering with 5v2A supply connected to display board microUSB.

Raspi boots up and works with hdmi port (although hdmi display is unplugged for testing)
Raspi works with SSH.

reset all 3 cables (2 from display and 1 from raspi)
reset all 4 wires (5V, Gnd, SCL, SDA)

Any suggestions?


#2

First off, with a Pi 3B you don’t need the SCL and SDA. All you need is the 5V and Ground jumper wires. Also a 2A power supply may be iffy, don’t be surprised if you see the lightning bolt on screen once you get it working. Double check the ribbon cable going from the Pi’s DSI port to the display board. If you get it in upside down / reversed, the display won’t work. There are only contacts on one side, the other side is blue. Get it the wrong way around and its the same as having no cable plugged in. If that’s not it post back and we’ll keep looking.


#3

Just using 5V and Ground. Went to a 10A power supply. Reseated both ends of the ribbon cable going from the DSI port to the display board. Still nothing. (Thanks for the help)


#4

The big thing with the ribbon cable is making sure the contacts are the right way around.

I have the original V 1 of that display, hooked up to a Pi 3B. My power supply is also 5V and 10A. I did that for other reasons, it’s my bread board rig and wanted a nice beefy supply. I have my Pi and display powered via their respective Micro USB power jacks. I made my own custom cables. I basically just cut the end off of the cables and striped and soldered the wires at the power supply end of the cable. My power supply uses a barrel jack. There are Y cables out there to do it.


#5

The cables are in the right way around (per the installation graphic).
I can see the contacts on the cable are against the contacts on the connectors.


#6

Ok, thanks, just double checking. It’s an easy error to make, that leaves you scratching your head wondering why it doesn’t work.


#7

DSI enabled in Raspberry Pi configuration? Kind of pulling at straws now. I’m trying to remember my last install. I don’t remember having to do anything special, or having to hook up another monitor? I’m pretty certain I’m running Stretch on that PI too. If I get a chance I’ll boot it up and have a look see. Is there a power or status LED on the driver board? I can’t see one in the picture of the board? Mine is buried deep under a custom cover, I can’t see it at all. I’d have to disassemble things to get at it.

NOOBS or straight up Raspbian?


#8

No power on indicator, but since the display board is powering the PI, there is power flowing
Don’t know how to enable DSI, searching the web doesn’t show how.
I have
dtparam=i2c_arm=on
ignore_lcd=0

in congig.txt

using straight up Raspian.
I will take the display bezel apart and see in +5 is getting to the touchscreen.


#9

If you go click the Raspberry on the task bar, then go to Preferences > Raspberry Pi Configuration. It should be listed under the Interfaces tab. I’ll boot my Pi with that screen up to confirm that when I get a chance. It should be on but can’t hurt to double check. I have to go out for a bit at the moment. Will check it when i’m back home in an hour or so.


#10

Looks like I got it wrong, I see camera listed but no DSI listing. I think in earlier versions of Raspbian CSI and DSI were listed in there? I’ll have a look at my config.txt.


#11

In my config.txt I have the following:
interfaces
dtparam=i2c_arm=on

dtparam=audio=on

dtoverlay=i2c-rtc,ds3231 < I added this myself

enable_uart=0 < I may have added this too.

There is no “ignore_lcd=0” in my confix.txt file, remarked or otherwise. As a test, put a # in front of it and that line will be ignored.


#12

I took the ignore_lcd=0 out of config.
I have:
dtparam=i2c_arm=on
dtparam=audio=on

While monkeying with it (different combinations of powering the display and the pi and powering one first and then the other) It started working!

When I shut it down and removed power, it would not come back.
This happened twice.

I still haven’t figured out what will consistently make it come on…


#13

I would think it needs to be powered on when the Pi is booting up. Otherwise the Pi will go to HDMI. Having a monitor plugged into HDMI while its booting up might stop it from working too. I will try to test that latter on today.

Mine is powered by its MICRO USB power port, same as my Pi. Same power supply, basically a Y power cable.


#14

I can get the display to work very sporadically. I cannot find a pattern to making it work consistantly.


#15

Not sure if this will help or not, https://www.raspberrypi.org/forums/viewtopic.php?f=108&t=120398
Haven’t had a chance to fire mine up, will try to do that some time today. With and without an HDMI monitor connected.


#16

Mine uses the 7 inch touch screen even when I plug in an HDMI monitor. I hooked up my TV and it booted up to the Touchscreen. My TV appears to be getting a signal, just no picture. The no signal message goes away while my Pi is booted up, then comes back when I shut down. Nothing shows on the TV though. Cursor won’t move to it either. I’d say I have to do a config edit to use HDMI, or unplug my Pi Foundation touch Screen.

That being said, my guess is yours isn’t being detected on boot up. Not reliably anyway.


#17

Tried your suggestion, still not working.
I’ve even tried replacing the ribbon cable.

I’ve just about given up…


#18

How long have you had it, can you return it? If you can’t return it, maybe post on the Pi foundation forum. They may be better able to figure out what’s wrong than I can. They built it. Only other thing I can suggest is to try a different Pi. And a fresh out of the box image on that Pi’s SD card. There is a slim chance its not the display, its something not working correctly on the Pi.


#19

I’ve had id about 8 months, so it’s out of warranty.
I’ve tried a different pi.
I’ll try a fresh image.
If that doesn’t do it, I’ll try the Pi foundation forum.
Thanks for hanging in there with me…


#20

No problem. Hopefully somebody from the Pi foundation will give you a hand figuring out why its not working correctly…