Official 7" Raspberry Pi Touch Screen FAQ


How have I “switched back to HDMI”?: I’ve physically disconnected the touchscreen ribbon cable AND the four jumpers… and plugged the HDMI back in.

So, here’s what I’m looking for:

  1. I’d like to know how to “reset” the desktop environment optimized for HDMI (“arrow” as the mouse pointer; windows are “draggable”)
  2. I’d like to know how to change back to “touchscreen settings” when I re-attach the touchscreen

Maybe in addition to the physical disconnection, there was some other reconfiguration steps documented somewhere; that – I guess – is what I’m missing.



As far as I know, there are no configuration steps involved. However, I’ve got an HDMI display and a Pi connected to a 7" display in front of me, so I can give it a go and see if I get the same results.

Okay, it works perfectly fine for me so I figure there must be some other factors at play:

  1. What OS are you running on your Pi?
  2. Could you post the contents of your /boot/config.txt?
  3. Do you have any manual settings in /usr/share/X11/xorg.conf.d/ ?


@gadgetoid: thanks for trying to duplicate on your system. Just to be clear, can you tell me if this is “working for you”:

  • Install the touchscreen; works as expected. Shutdown.
  • Attach the HDMI connector (leaving the touchscreen connected); the desktop shows up on the HDMI monitor, and works as it “used to” before the touch screen was installed (and the touchscreen does nothing).

Is that right? That is the behavior that I’d like.

Here’s my system: I have a RPi 2, Wheezy upgraded to Jessie. I have very little customization of /boot/config.txt. I have NO manual settings in xorg.confg.d.

I’m getting the sense this is either an X-related problem or related to this OS being upgraded-to-Jessie.

I guess this is my plan: I’m going to try this with a Pi 3 with “fresh from NOOBS” install of Jessie. If I see the same thing there, I’ll get back to you. If I don’t, I’ll try a reinstall of Jessie on my Pi 2.

Thanks so far…


In my experience, the touchscreen always takes precedence and the HDMI display will simply be black in this configuration.

However; Leaving the display connected, but un-powered, works for me (ie: I get a sane desktop environment with the correct cursor and window behavior). Is this what you meant?

I’m guessing your Raspbian install is broken in some way, and a fresh from NOOBS install is most probably the best thing to try.


Have the Raspberry Pi 7 inch touch screen, raspberry pi 3 and official raspberry pi power supply. Connected everything. Display shows only a rainbow of colors. Tried reconnecting ribbon cables. Raspian OS flashed onto micro sd card works fine with 3 inch Raspberry touch screen. Replaced 7 inch touchscreen and still the same problem. Tried jumpering boards between Rasp pi and adapter board. No luck. Used a dual micro usb cable connected to pi and display adapter ports and still no luck. Any other suggestions would be appreciated.


Great article - thanks!!

I just got my touchscreen yesterday, been playing with it, ended up installing xscreensaver as I want the screen to go blank after 1 minute, and when I touch it I want that touch not to go to the underlying software (in case the user activates a button).

However, it seems that if I leave it for ages (an hour?) the xscreensaver doesn’t change the screen from being black again - is there anywhere I can query to see what the pi thinks the state of the touchscreen is?

I’m using the power saving options in the xscreensaver config. (I use xscreensaver-demo to configure the screensaver)

I’m using a pi 3 BTW with all the latest software


Might be worth trying this



Excellent, thanks! I’ll try that


Hi, apologies for what I’m guessing is a pretty stupid question - however after hours of research this seems to be the most knowledgable place with regards to Touchscreen conversations.

I recently purchased one with the hope of using it alongside my TV screen as a Plex/Kodi interface, and as you can probably guess faced issues with the lack of a second framebuffer.

Is there anyway around this - I have tried so much in terms of config.txt settings, Plex settings, etc… I even thought that if I wired a seperate power connection to the Pi and Screen I could whip out the power to the screen when the movie starts and it would switch to the HDMI connection - but alas this doesnt even seem to work.

If somebody could just tell me its not possible that would save me wasting what seems to have been days now trying to find a solution.

Many thanks,


As far as I know it’s impossible, but certain movie players, given the right options, will play to the HDMI screen. Do you have any idea what player back-end you have in Plex/Kodi?

And by “impossible” I mean “difficult” since we already know omxplayer can output to HDMI by doing:

omxplayer --display=5 video.mkv

So if kodi uses omxplayer to play videos then it must be achievable, somehow.


How can The raspberry pi computer 3/CM3 drive 7 inch official touch screen ?

How to driver two 7 inch official touch screen by CM3 port DISP0 and DISP1 ?


You said that you have only tested the screen with Raspbian. I installed the Pi-Optimised version of Xubuntu on my Pi3b, and it works with touch out of the box, the only things you need to change are install onboard and append the rotation fix to /boot/config.txt. It is perfect for light browsing, and I use it with MyStudyLife to pack my bag for college. I really reccommend to anyone who wants a small device for light media playback/server/web browsing !


As for cloning the official 7" Touch LCD to HDMI: yes, that actually works, but is little known. I’ve successfully done it myself and documented it here:


A post was split to a new topic: Stop motion help


Found this note on another site

these cables manage the power supply from the Pi to the display, but also transmit touch information to earlier Pi models – on newer models, the green and yellow I2C connection is built into the ribbon cable, so they aren’t actually needed.


Hi - I’m sorry to butt in to an old thread but this looks like somewhere I can get some real help!

I’m trying to control my Pi’s 7’’ backlight.

I’ve updated my Pi (apt-get update)
upgraded my Pi (apt-get upgrade)
upgraded my firmware (rpi-upgrade)

But I still don’t even have the /sys/class/backlight/rpi_backlight directory or files.
I’ve done some digging and I think these are supposed to be symlinked to /sys/devices/platform/rpi_backlight
which is also missing.

Am I missing a package or something, please?


Hi 0ldman, I don’t know if it’s what you need (or if you still need help) but have you run this command:
curl | bash
I found that in Pimoroni’s getting started tutorial


Hi, I’m trying to get my screen up and running, but the screen only displays white. I’ve checked the ribbon connector multiple times, and I believe both ends are fully connected. I’ve been using the GPIO to power the screen from the Pi, but someone above suggested this might be too much of a draw for some power supplies, so I’ve also been experimenting with two power supplies, but the results have been the same.

Interestingly I have got the /sys/class/backlight/rpi_backlight directory, and changing the brightness value changes the screen brightness, so the Pi and screen are talking, just not sending any pictures.

Google seems fresh out of other people who have had this issue… I hope someone here can shed some light :)