On off shim instal problem


#1

Hi everyone , another newb with a problem!
I just got hold of the Zero W and I’m making myself a network stereo out of it but wanted to be able to switch it on /off easily so purchased the on/off shim as it looked perfect , however, trying to instal the software for it I get the message that it’s not compatible with my operating system, I don’t see any specific requirements listed anywhere for it so I’m a little confused as to the reason, I’m not sure where to begin to solve this or even if it is solvable , any help would be appreciated, I’m running Volumio2 and I’m pretty sure it’s all up to date, sorry for the blurry pic had to use the iPad…


#2

Right , so I’ve just spent the last hour or two trying to figure this out, I stumbled over the GitHub which says something about using setup.sh but I can’t figure out how to as it assumes the reader already knows …I’ve downloaded the file to the pi and it’s showing in the main folder as onoffshim but I can’t figure out how to run it, when I try Sudo apt-get install onoffshim it tells me it can’t find the file …I’m not even sure if that’s the right command but after scouring the web it’s the closest I’ve got to solving this lol

Also tired downloading the clean-shutdown files from GitHub and installing them the same way with the same result…thought maybe I had to unzip them first , so installed zip/unzip but when I run unzip onoffshim or clean-shutdown it tells me it’s not a zip file…

I’m trying to figure this out but I’ve hit the end of my knowledge/teather and really could do with some guidance here…


#3

I’m going to open the script to volumio. Can’t see why it wouldn’t work, however it has not been tested, which is why the script is locking that distribution out.


#4

There you go, it should run now.

Let us know if any problem but I don’t think there will be any issue in operation.


#5

Thanks for that RogueM , it seemed to install ok however there’s a problem…the red led on the onoffshim only lights when I plug power into the pi itself nothing happens when I plug into it, the button doesn’t seem to do anything and when I plug power into the pi it boots up as normal then shuts down leaving a red light on the onoffshim …I’m gonna quit for the day on this but if you have any ideas I’d appreciate hearing them :)


#6

Sorted , think it was my terrible soldering skills ;) seems to be working well …thank you for the help