PanTiltHead Servo Gears Grinding


#1

I purchased the Pan-Tilt Kit and after connecting it to the Pan-Tilt HAT based on the “Assembling Pan-Tilt HAT” instructions. I tried using the example code (neopixel.py) provided by in the GitHub repo, and also my own code calibrating the servo range (575-2325) as specified in the Pimoroni forums. The result of all my testing is the pan servo immediately swings to the far right (-90?) and grinds for the duration of the run regardless of movement instructions provided.

This is a video:

AdaFruit has replaced both the hat and servos, but the behavior continues with the new set. What am I doing wrong?

FWIW I’ve tried switching the servo connections (pan servo -> Servo 2, tilt servo -> Servo 1), but the pan servo still behaves the same way.


#2

I’d hook a servo directly up to the Pi without the Hat, and test it that way. All by itself not mounted to anything. Once you get one working correctly, swap it out for each of the others you have. If they all work OK, its not the servo. If one or more behave weird, find two that work. Then move on. I’d want to know if the servo’s are OK and go from there.
This might help with that, https://www.youtube.com/watch?v=ddlDgUymbxc


#3

You may also want to post your test code. PS, your video shows an unsupported type error.


#5

Here’s a direct link, the forum seems to want to try and render it within the post.

https[:]//www.dropbox.com/s/05w16gmhuquedj3/IMG_5823.mp4?dl=0


#6

I tried the link, and the servos work fine when controlled directly by the RPi. This leaves the HAT. Could it be possible that I received two bad HATs?

As for my sample code, I’m just trying to use the example provided in the PanHatTilt repo:


#7

If you switch the cables, swapping the two servos, plugging the tilt servo into the pan header. Does the issue move to the other servo, the one now plugged into the pan header? It sounds like its the Hat. Maybe they had a bad run? Going to go watch NFL football paly offs, so I likely won’t reply again until tomorrow. ;)


#8

Thank you for your help. It appears to be bad servos.


#9

So do you have a working setup now, two good servo’s?