pHat DAC no sound on Rpi Zero


#1

I have just received and followed installation procedures and still can’t get sound. I am running updated and upgraded jessie lite.

Here is a picture of the soldering:

Here is output for aplay -L

null
Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndrpihifiberry
snd_rpi_hifiberry_dac,
Default Audio Device
sysdefault:CARD=sndrpihifiberry
snd_rpi_hifiberry_dac,
Default Audio Device
dmix:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dac,
Direct sample mixing device
dsnoop:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dac,
Direct sample snooping device
hw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dac,
Direct hardware device without any conversions
plughw:CARD=sndrpihifiberry,DEV=0
snd_rpi_hifiberry_dac,
Hardware device with all software conversions

Here is output of lsmod:

Module Size Used by
ctr 4262 6
ccm 9232 3
arc4 2076 2
rt2800usb 18973 0
rt2800lib 82219 1 rt2800usb
rt2x00usb 12964 1 rt2800usb
rt2x00lib 49062 3 rt2800lib,rt2800usb,rt2x00usb
mac80211 650611 3 rt2800lib,rt2x00lib,rt2x00usb
spidev 7034 0
cfg80211 525742 2 rt2x00lib,mac80211
rfkill 21373 2 cfg80211
crc_ccitt 1732 1 rt2800lib
joydev 9354 0
evdev 11746 4
snd_usb_audio 143956 0
snd_hwdep 6479 1 snd_usb_audio
snd_usbmidi_lib 22479 1 snd_usb_audio
snd_rawmidi 23727 1 snd_usbmidi_lib
snd_seq_device 5266 1 snd_rawmidi
snd_soc_hifiberry_dac 3123 0
i2c_bcm2835 6433 0
snd_soc_bcm2835_i2s 6283 2
spi_bcm2835 7424 0
regmap_mmio 3977 1 snd_soc_bcm2835_i2s
snd_soc_pcm5102a 2245 1
bcm2835_gpiomem 3791 0
snd_soc_core 175744 3 snd_soc_bcm2835_i2s,snd_soc_hifiberry_dac,snd_soc_pcm5102a
snd_compress 10144 1 snd_soc_core
snd_pcm_dmaengine 6002 1 snd_soc_core
snd_pcm 97825 4 snd_usb_audio,snd_pcm_dmaengine,snd_soc_core,snd_soc_hifiberry_dac
snd_timer 22706 1 snd_pcm
snd 68784 9 snd_compress,snd_hwdep,snd_usb_audio,snd_timer,snd_rawmidi,snd_usbmidi_lib,snd_seq_device,snd_soc_core,snd_pcm
fixed 3029 0
uio_pdrv_genirq 3718 0
uio 10166 1 uio_pdrv_genirq
ipv6 384468 26

and here is output of cat /etc/asound.conf

pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}

and cat ~/.asoundrc

pcm.!default {
type hw card 0
}
ctl.!default {
type hw card 0
}

the sound portion of config.txt

Uncomment some or all of these to enable the optional hardware interfaces

dtoverlay=i2s-map
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=spi=on

Uncomment this to enable the lirc-rpi module

#dtoverlay=lirc-rpi

Additional overlays and parameters are documented /boot/overlays/README

Enable audio (loads snd_bcm2835)

dtparam=audio=on
enable_uart=0
dtoverlay=hifiberry-dac

Any help would be greatly appreciated.

Abovedmc


#2

Hi there Abovedmc,
What are you using to test that you’re getting an audio output? Make sure you’re not using omxplayer, since it doesn’t support alsa, which is used to output to the pHat DAC.


#3

I am using speaker-test -c2 wav, connected to a powered speakers known to
work.

Thanks for your prompt response. I have spent hours trying to get output.

Abovedmc


#4

Update on my problem described above. I removed the pHat DAC from Rpi Zero and attached it to my Rpi 3, Running Musicbox on raspbian which was outputting to USB dac, I modified /boot/config.txt by uncommenting dtoverlay=hifiberry-dac
I modified /home/mopidy/mopidy.conf Audio Settings by commenting out downsample_usb_usb = true
in same area I changed output+ " " to output = "hifiberry-dac"
and scan_always = True.

Was then able to use speaker-test successfully.

Only problem was that after these changes to Musicbox I can no longer login.